Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3486 closed defect (fixed)

bicubiclin typo in www.ffmpeg.org/ffmpeg-scaler.html

Reported by: cyril Owned by:
Priority: minor Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: when I try to resize using the bicubiclin algorithm, I just get an error, while others as sinc, lanczos or vanilla bicubic are working fine.

Also when trying to programmatically use SWS_BICUBLIN with sws_getCachedContext(), I get a C runtime exception.

Maybe, SWS_BICUBLIN has been removed from FFmpeg?

How to reproduce:

% ffplay -i <any video file>  -sws_flags bicubiclin
ffplay version N-61678-gd003a0c Copyright (c) 2003-2014 the FFmpeg developers
  built on Mar 21 2014 22:08:13 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable
-zlib
  libavutil      52. 67.100 / 52. 67.100
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 34.101 / 55. 34.101
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  5.102 /  2.  5.102
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[swscaler @ 00000000029c8e00] [Eval @ 000000000022f5b0] Undefined constant or mi
ssing '(' in 'bicubiclin'
[swscaler @ 00000000029c8e00] Unable to parse option value "bicubiclin"
Error setting option sws_flags.
Failed to set value 'bicubiclin' for option 'sws_flags': Error number -22 occurr
ed

Change History (5)

comment:1 Changed 5 years ago by cehoyos

Please add a working command line (of the older FFmpeg version when this used to work) including console output if you want me to do the regression tests or tell us the offending commit if you do the regression test yourself.

comment:2 Changed 5 years ago by heleppkes

The option is called "bicublin", not "bicubiclin". If its spelled wrong, swscale won't recognize it and complain.

comment:3 Changed 5 years ago by cyril

thanks heleppkes. The doc at http://www.ffmpeg.org/ffmpeg-scaler.html should be changed because it's telling us to use "bicubiclin"...

comment:4 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from SWS bicubiclin resizing filter doesn't work anymore to bicubiclin typo in www.ffmpeg.org/ffmpeg-scaler.html

fixed the docs, or rather they will fix themselfs now when they are rebuild the next time

comment:5 Changed 5 years ago by cehoyos

  • Component changed from swscale to documentation
  • Priority changed from normal to minor
Note: See TracTickets for help on using tickets.