Opened 5 years ago

Closed 5 years ago

#345 closed defect (invalid)

Issues with 0.7.1 release on Windows

Reported by: linga Owned by:
Priority: normal Component: build system
Version: 0.7.1 Keywords: 0.7.1
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am facing 2 issues with '0.7.1' release on Windows. I didnt face these issues with 0.6.3 release.

Issue1
When I try to build 0.7.1 using './configure --prefix=/d/projects/ffmpeg/build_temp/ --enable-memalign-hack --enable-shared --disable-static' option, the build stops displaying yasm not found, use --disable-yasm for a crippled build

Issue2
When I proceed with an extra --disable-yasm option, the build is successful. But runtime The program can't start because pthreadGC2.dll is missing from your computer. Try reinstalling the program to fix this problem error message is displayed and the execution stops.

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Issue 1 should be obvious: FFmpeg performance will be significantly lower if you don't have yasm installed at build time, so you have to explicitly confirm that you want such a build.

Issue 2: pthreads get auto-detected if they are installed (they come with the default mingw installation), you have to provide the missing dll for such a build (copy /mingw/bin/pthreadGC2.dll into the same directory as ffmpeg.exe), if you want to build without pthreads, pass --enable-w32threads to configure.

Note: See TracTickets for help on using tickets.