Opened 5 years ago

Closed 5 years ago

#3357 closed defect (fixed)

png decoder too strict for samples that all web browsers show

Reported by: cyril Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: png
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: FFplay cannot read and display attached png file

How to reproduce:

% ffplay 1600_1200.png
ffplay version N-60202-g6369766 Copyright (c) 2003-2014 the FFmpeg developers
  built on Jan 27 2014 02:02:32 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 63.100 / 52. 63.100
  libavcodec     55. 49.100 / 55. 49.100
  libavformat    55. 26.100 / 55. 26.100
  libavdevice    55.  5.102 / 55.  5.102
  libavfilter     4.  1.101 /  4.  1.101
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
[png @ 00000000003385c0] No bytes left vq=    0KB sq=    0B f=0/0
Input #0, image2, from 'G:\1600_1200.png':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: png, rgb24, 1600x1200, 25 tbr, 25 tbn, 25 tbc
[png @ 000000000033b3a0] No bytes left vq=    0KB sq=    0B f=0/0
    nan M-V:    nan fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Attachments (2)

1600_1200.png (1.2 MB) - added by cyril 5 years ago.
patchpng.diff (451 bytes) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by cyril

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords png added
  • Reproduced by developer set
  • Status changed from new to open

Several applications including ImageMagick? fail for the sample, attached poc allows to decode the image.

comment:2 Changed 5 years ago by cehoyos

The image works fine with IE (since version 9), Firefox, Safari, Opera, Chrome and Maxthon.

comment:3 Changed 5 years ago by cehoyos

  • Summary changed from FFplay cannot read and display attached png file to png decoder too strict for samples that all web browsers show

comment:4 Changed 5 years ago by richardpl

IMHO patch should be sent to mailing list.

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in 666749f6 - thank you for the sample!

Note: See TracTickets for help on using tickets.