Opened 8 years ago

Closed 2 years ago

#3173 closed enhancement (wontfix)

afade-fadeout on pipe:0 stream

Reported by: Katie Holly Owned by:
Priority: wish Component: avfilter
Version: git-master Keywords: afade
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello,

is it possible to implement a way to apply fadeout-effects to a pipe:0-stream? I think this is possible when buffering the input audio for the time of fadeout-seconds specified and when pipe:0 has been closed, apple the effect on the buffer. Is this correct and can this be implemented in FFmpeg?

Thanks!

Change History (6)

comment:1 by Carl Eugen Hoyos, 8 years ago

Component: FFmpegavfilter
Keywords: afade added
Status: newopen
Version: unspecifiedgit-master

Related to ticket #2631.
Note that most developers believe that this is not a good idea.

comment:2 by Katie Holly, 8 years ago

Why is that? Please explain, because i don't think that this is not a good idea.

/Edit: Ok, i overlooked the link to ticket #2631 but still can't see why this isn't a good idea so far...

Last edited 8 years ago by Katie Holly (previous) (diff)

comment:3 by Elon Musk, 8 years ago

buffering needs memory, better approach would be to know when audio ends.

comment:4 by Katie Holly, 8 years ago

Yeah, i know that it needs more memory. I think, exactly the raw format size of how long the audio buffer is.

A wav file (pcm_s16le, Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16, 1411 kb/s) with a length of time=00:00:04.98 has exactly

fusl@thinkbook  ffmpegtest   ls -alF test.wav
-rw-r--r-- 1 fusl users 875788 Nov 29 14:57 test.wav

And i don't think that 875KiB would use much more memory inside ffmpeg.

Also i think that a notice in the documentation and the manual page, that it COULD use much memory when input type is a stream, is enough, isn't it?

comment:5 by Elon Musk, 6 years ago

I guess you could use asetnsamples to set number of samples per frame to some high number so fading is done in one go.

comment:6 by Elon Musk, 2 years ago

Resolution: wontfix
Status: openclosed
Note: See TracTickets for help on using tickets.