Opened 5 years ago

Closed 3 years ago

#3084 closed defect (needs_more_info)

Realmedia stream works better with MPlayer

Reported by: cehoyos Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: rtsp real
Cc: underground78@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

(ticket #3042)
The following Realmedia stream plays fine with mplayer -demuxer lavf -vc ffrv40 -ac ffcook (and the native MPlayer demuxer), plays badly showing artefacts and missing audio with ffplay, transcoding with ffmpeg is impossible afaict:

$ ffplay rtsp://apreal03.triara.com/broadcast/canalcongreso.rm
ffplay version N-57421-g2cf9448 Copyright (c) 2003-2013 the FFmpeg developers
  built on Oct 26 2013 01:31:55 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      52. 47.101 / 52. 47.101
  libavcodec     55. 38.101 / 55. 38.101
  libavformat    55. 19.104 / 55. 19.104
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 89.100 /  3. 89.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Truncating packet of size 4352 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet
Truncating packet of size 4352 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet
Truncating packet of size 4352 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet

...

Truncating packet of size 224 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet
Truncating packet of size 224 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet
Truncating packet of size 224 to 26
[rdt @ 0x7f0230008080] Impossibly sized packet
[rtsp @ 0x7f0230000920] Could not find codec parameters for stream 1 (Video: rv40 (RV40 / 0x30345652), yuv420p, 720x480): no frame in rv30/40 and no sar
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, rtsp, from 'rtsp://apreal03.triara.com/broadcast/canalcongreso.rm':
  Metadata:
    title           : canalcongreso.rm
    comment         : <No author> <No copyright>
  Duration: N/A, start: 0.000000, bitrate: 76 kb/s
    Stream #0:0: Video: rv40 (RV40 / 0x30345652), yuv420p, 720x480, 60 kb/s, 15 fps, 15 tbr, 1k tbn, 1k tbc
    Stream #0:1: Video: rv40 (RV40 / 0x30345652), yuv420p, 720x480, 15 fps, 15 tbr, 1k tbn, 1k tbc
    Stream #0:2: Audio: cook (cook / 0x6B6F6F63), 22050 Hz, stereo, fltp, 16 kb/s
[rv40 @ 0x7f02300c0500] First slice header is incorrect
[rv40 @ 0x7f0230093b60] Context scratch buffers could not be allocated due to unknown size.
[rv40 @ 0x7f0230093b60] First slice header is incorrect
[rv40 @ 0x7f02300daec0] Context scratch buffers could not be allocated due to unknown size.
[rv40 @ 0x7f02300daec0] First slice header is incorrect
[rv40 @ 0x7f02300f93c0] Context scratch buffers could not be allocated due to unknown size.

...

[rv40 @ 0x7f02300c0500] First slice header is incorrect
[rv40 @ 0x7f0230093b60] Context scratch buffers could not be allocated due to unknown size.
[rv40 @ 0x7f0230093b60] First slice header is incorrect
[rv40 @ 0x7f02300daec0] Context scratch buffers could not be allocated due to unknown size.
[rv40 @ 0x7f02300daec0] First slice header is incorrect
[rv40 @ 0x7f02300f93c0] Context scratch buffers could not be allocated due to unknown size.
[rv40 @ 0x7f02300f93c0] warning: first frame is no keyframe
[rv40 @ 0x7f02300f93c0] Slice indicates MB offset 736, got 464
[rv40 @ 0x7f02300f93c0] Dquant for P-frame
[rv40 @ 0x7f023022c340] Slice indicates MB offset 369, got 84
[rv40 @ 0x7f02300f93c0] Slice indicates MB offset 1104, got 871
[rv40 @ 0x7f02300f93c0] marking unfished frame as finished
[rv40 @ 0x7f02300f93c0] concealing 714 DC, 714 AC, 714 MV errors in P frame
[rv40 @ 0x7f023022c340] Dquant for B-frame
[rv40 @ 0x7f023022c340] Slice indicates MB offset 737, got 622
[rv40 @ 0x7f023022c340] marking unfished frame as finished
[rv40 @ 0x7f023022c340] concealing 560 DC, 560 AC, 560 MV errors in B frame
[rv40 @ 0x7f023028c420] Changing dimensions to 368x256   0B f=0/0
[rv40 @ 0x7f023034c5e0] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02303ac6c0] First slice header is incorrect
[rv40 @ 0x7f02300c0500] First slice header is incorrect
[rv40 @ 0x7f0230093b60] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02300daec0] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02300f93c0] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f023022c340] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f023028c420] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02302ec500] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f023034c5e0] First slice header is incorrect
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 184, got 92
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 92, got 276
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 276, got 184
[rv40 @ 0x7f02300c0500] concealing 0 DC, 0 AC, 0 MV errors in B frame
[rv40 @ 0x7f02302ec500] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02303ac6c0] First slice header is incorrect
[rv40 @ 0x7f02300c0500] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f0230093b60] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02300daec0] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02300f93c0] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f023022c340] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f023028c420] First slice header is incorrect  0B f=0/0
[rv40 @ 0x7f02302ec500] First slice header is incorrect
[rv40 @ 0x7f023034c5e0] First slice header is incorrect  0B f=1/0
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 184, got 92=2/1
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 92, got 276
[rv40 @ 0x7f02300c0500] Slice indicates MB offset 276, got 184
[rv40 @ 0x7f02300c0500] concealing 0 DC, 0 AC, 0 MV errors in P frame
[rv40 @ 0x7f023034c5e0] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f02303ac6c0] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f02300c0500] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f0230093b60] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f02300daec0] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f02300f93c0] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f023022c340] First slice header is incorrect  0B f=2/1
[rv40 @ 0x7f023028c420] First slice header is incorrect  0B f=2/1

Change History (3)

comment:1 Changed 5 years ago by Underground78

  • Cc underground78@gmail.com added

comment:2 Changed 3 years ago by compn

  • Status changed from new to open

another mbr problem no doubt.

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from open to closed

404 =-(

Note: See TracTickets for help on using tickets.