Opened 6 years ago

Closed 6 years ago

#3037 closed defect (fixed)

installation errors

Reported by: spookybathtub Owned by:
Priority: minor Component: build system
Version: git-master Keywords: osx regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When I install the latest build from git master, I get lots of errors during make. Note I am not talking about the deprecated warnings, but scroll down further to see the errors. After installation, ffmpeg seems to be working properly so far, so I'm not sure what the errors mean.
configure output: http://pastebin.com/TUzLaH1s
make output: http://pastebin.com/0HEcJPRz

After installation, output of ffmpeg -version:

ffmpeg version N-56979-g162e22e
built on Oct  8 2013 12:15:29 with llvm-gcc 4.2.1 (LLVM build 2336.11.00)
configuration: --arch=x86_64 --enable-gpl --enable-version3 --enable-postproc --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libass --enable-libopenjpeg --enable-openssl --enable-libopus --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-yasm --enable-swscale --enable-avfilter --enable-libmodplug --enable-libbluray --enable-gnutls --enable-shared --enable-pthreads --enable-nonfree --enable-opencl --enable-avresample
libavutil      52. 46.101 / 52. 46.101
libavcodec     55. 35.100 / 55. 35.100
libavformat    55. 19.100 / 55. 19.100
libavdevice    55.  4.100 / 55.  4.100
libavfilter     3. 88.101 /  3. 88.101
libavresample   1.  1.  0 /  1.  1.  0
libswscale      2.  5.101 /  2.  5.101
libswresample   0. 17.103 /  0. 17.103
libpostproc    52.  3.100 / 52.  3.100

Change History (5)

comment:1 Changed 6 years ago by llogan

  • Component changed from avfilter to undetermined
  • Keywords installation removed

To make this a valid ticket please include all relevant information in the report itself instead of providing links to third-party locations.

comment:2 Changed 6 years ago by cehoyos

  • Priority changed from normal to minor

Please run make distclean && ./configure and post the complete, uncut console output of the following command here:

$ make V=1 libavcodec/x86/ac3dsp.o

comment:3 Changed 6 years ago by spookybathtub

$ make V=1 libavcodec/x86/ac3dsp.o
touch .version
yasm -f macho64 -m amd64 -DPIC -DPREFIX -I./ -I.// -Pconfig.asm -I libavcodec/x86/ -M -o libavcodec/x86/ac3dsp.o libavcodec/x86/ac3dsp.asm > libavcodec/x86/ac3dsp.d
yasm -f macho64 -m amd64 -DPIC -DPREFIX -I./ -I.// -Pconfig.asm -I libavcodec/x86/ -o libavcodec/x86/ac3dsp.o libavcodec/x86/ac3dsp.asm
strip: unrecognized option: -wN
Usage: strip [-AnuSXx] [-] [-d filename] [-s filename] [-R filename] [-o output] file [...] 
make: [libavcodec/x86/ac3dsp.o] Error 1 (ignored)
Last edited 6 years ago by cehoyos (previous) (diff)

comment:4 Changed 6 years ago by cehoyos

  • Component changed from undetermined to build system
  • Keywords osx regression added
  • Status changed from new to open

Apparently a regression since 3d5a995 / e52567c

comment:5 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Vittorio Giovara since 71b95f2a

Note: See TracTickets for help on using tickets.