Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#2974 closed license violation (fixed)

Plex Media Server: LGPL/GPL violation

Reported by: 11rcombs Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: Plex
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

http://www.plexapp.com/
Plex Media Server includes 2 transcoder binaries: Plex Transcoder and Plex New Transcoder. Both are versions of FFmpeg, modified to different degrees. Both have libx264 compiled in. No source code for either is available anywhere, nor is FFmpeg's license shown anywhere on the site or in the program as far as I can see. The lead developer seems to believe that he doesn't have to distribute the source for some reason, and won't listen to me regarding it.
Could somebody tell them (via email or the forums or something) that they do, in fact, have to make the source of their modified transcoders available?

Change History (6)

comment:1 Changed 4 years ago by 11rcombs

It looks like there were some miscommunications along the line. The source is evidently available upon request (as required by GPL), but that fact is not mentioned anywhere in the program or on the website, and the GPL isn't reproduced there. So all they really need are some website changes, which I'll be poking them about.

comment:2 in reply to: ↑ description Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Priority changed from important to normal

Replying to 11rcombs:

The lead developer seems to believe that he doesn't have to distribute the source for some reason, and won't listen to me regarding it.

This is what all license violators believe (or actually: claim to believe), I don't see how he would trust any FFmpeg developer more than you (or in other words: I suspect he knows very well what he is doing and believes he has thought this through).

comment:3 Changed 4 years ago by anssi

I've contacted them and they assured me it (missing license, missing source) will be fixed ASAP, but we'll see.

The transcoders are built with options making them GPLv3, with which just a written offer for source code is not enough for non-physical products AFAICS (sec 6(b)).

comment:4 Changed 4 years ago by patters

Any updates on this? Can't FFmpeg project members get legal support from http://gpl-violations.org/ or the Free Software Foundation? Plex is unfairly making a lot of money off the hard work of others.

comment:5 Changed 4 years ago by 11rcombs

  • Resolution set to fixed
  • Status changed from new to closed

A LICENSE file is now included with Plex Media Server downloads, which includes the text of the relevant GPL licenses and a link to the full required source code. This happened a few months ago, but never ended up getting mentioned here. Closing!

comment:6 Changed 3 years ago by jabbera

While the code for both transcoders are available I don't see the media server code even though they say it's used.

"Plex Transcoder and the Plex Media Server contain code from ffmpeg: http://files.plexapp.com/elan/ffmpeg/PlexTranscoder.tar.bz2"

Note: See TracTickets for help on using tickets.