Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2821 closed defect (duplicate)

vob file couldn't seek to the beginning

Reported by: hxuanyu Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegps seek
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I found this issue when developing our videoplayer. While this vob file can be played (file open and frame read ok), after av_seek_frame is called to seek to the beginning of the video, subsequent av_read_frame returns frames with incorrect pts/dts and just after short time (1-2 seconds) av_read_frame returns -1

This issue can be reproduced with ffplay. (while played with -ss 0, no video/sound could be played)

test file is here: https://dl.dropboxusercontent.com/u/89678527/Test_001.vob

$ gdb ffplay.exe
GNU gdb (GDB) 7.5.50.20120815-cvs (cygwin-special)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-cygwin".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /cygdrive/c/Users/Alex/Downloads/ffmpeg-20130728-git-768e40b-win32-static/ffmpeg-20130728-git-768e40b-win32-static/bin/ffplay.exe...(no debugging symbols found)...done.
(gdb) r -ss 0 -i Downloads/Test_001.vob
Starting program: /cygdrive/c/Users/Alex/Downloads/ffmpeg-20130728-git-768e40b-win32-static/ffmpeg-20130728-git-768e40b-win32-static/bin/ffplay.exe -ss 0 -i Downloads/Test_001.vob
[New Thread 6436.0x334]
[New Thread 6436.0x4e4]
[New Thread 6436.0x1eec]
[New Thread 6436.0x1bd8]
[New Thread 6436.0x1a38]
[New Thread 6436.0x16ec]
[New Thread 6436.0x8bc]
[New Thread 6436.0x1050]
[New Thread 6436.0x914]
[New Thread 6436.0xe20]
[New Thread 6436.0xc68]
[New Thread 6436.0x1bac]
[New Thread 6436.0x1d0c]
[New Thread 6436.0x19b8]
[New Thread 6436.0x1828]
[New Thread 6436.0x1d80]
[New Thread 6436.0x1b04]
[New Thread 6436.0x1900]
[New Thread 6436.0x18e4]
[New Thread 6436.0xcfc]
[New Thread 6436.0x17c0]
[New Thread 6436.0x1fe8]
[New Thread 6436.0xe98]
[New Thread 6436.0x1f48]
[New Thread 6436.0xd80]
[New Thread 6436.0x1d70]
[New Thread 6436.0x19fc]
[New Thread 6436.0x1b90]
[New Thread 6436.0x1ec0]
[New Thread 6436.0x1dcc]
[New Thread 6436.0x194]
[New Thread 6436.0x1208]
[New Thread 6436.0x1f40]
[New Thread 6436.0x1fb4]
[New Thread 6436.0x1b1c]
[New Thread 6436.0x434]
[New Thread 6436.0x150]
ffplay version N-55020-g768e40b Copyright (c) 2003-2013 the FFmpeg developers

built on Jul 28 2013 18:01:30 with gcc 4.7.3 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 40.100 / 52. 40.100
libavcodec 55. 19.100 / 55. 19.100
libavformat 55. 12.102 / 55. 12.102
libavdevice 55. 3.100 / 55. 3.100
libavfilter 3. 81.103 / 3. 81.103
libswscale 2. 4.100 / 2. 4.100
libswresample 0. 17.103 / 0. 17.103
libpostproc 52. 3.100 / 52. 3.100

Last message repeated 13 times 0KB vq= 0KB sq= 0B f=0/0

Input #0, mpeg, from 'Downloads/Test_001.vob':

Duration: 00:00:22.34, start: 1.084500, bitrate: 5626 kb/s

Stream #0:0[0x1bf]: Data: dvd_nav_packet
Stream #0:1[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [SAR 8:9 DAR 4:3], max. 9800 kb/s, 29.33 fps, 59.94 tbr, 90k tbn, 59.94 tbc
Stream #0:2[0x80]: Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s

[ac3 @ 03b4c8c0] frame sync error 13KB vq= 0KB sq= 0B f=0/0
[mpeg2video @ 03b73700] ac-tex damaged at 13 16

Last message repeated 1 times 12KB vq= 0KB sq= 0B f=0/0

[mpeg2video @ 03b73700] Warning MVs not available
[mpeg2video @ 03b73700] concealing 630 DC, 630 AC, 630 MV errors in P frame
[ac3 @ 03b4c8c0] incomplete frame 3KB vq= 0KB sq= 0B f=0/0

7.29 A-V: -0.625 fd= 0 aq= 0KB vq= 0KB sq= 0B f=0/0

[Inferior 1 (process 6436) exited normally] 0KB sq= 0B f=0/0

Change History (4)

comment:1 follow-up: Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mpegps seek added
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from unspecified to git-master

I suspect this is a duplicate of ticket #1438, sample uploaded to http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket1438/

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by hxuanyu

Replying to cehoyos:

I suspect this is a duplicate of ticket #1438, sample uploaded to http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket1438/

Hi Cehoyos,

As I said I found this issue when I seek to the beginning of the video while playing, and then
all subsequent av_read_frame returns incorrect data. Could you confirm ffplay -ss 0 fails because of the same cause. So that I can just wait for your fix. Thanks

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by cehoyos

Replying to hxuanyu:

Replying to cehoyos:

I suspect this is a duplicate of ticket #1438

Could you confirm ffplay -ss 0 fails because of the same cause.

Unfortunately, I can't. Sorry.

comment:4 in reply to: ↑ 3 Changed 5 years ago by hxuanyu

Replying to cehoyos:

Replying to hxuanyu:

Replying to cehoyos:

I suspect this is a duplicate of ticket #1438

Could you confirm ffplay -ss 0 fails because of the same cause.

Unfortunately, I can't. Sorry.

Thanks Cehoyos,
Or is their anyway to reproduce this with ffplay? I mean is there anyway, after ffplay has started videoplaying for a while, ask it seek back to the beginning?

Note: See TracTickets for help on using tickets.