Opened 3 years ago

Closed 3 years ago

#2810 closed defect (fixed)

unsupported wav

Reported by: richardpl Owned by:
Priority: important Component: avformat
Version: git-master Keywords: regression wav dca probe
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by richardpl)

Summary of the bug:
Wav file produced with audacity is detected to have dca codec but it is actually pcm.
How to reproduce:

> ffprobe steps-stereo-16b-44khz.wav                                                                                                                           
ffprobe version N-54927-g733f6df Copyright (c) 2007-2013 the FFmpeg developers
  built on Jul 25 2013 13:55:44 with FreeBSD clang version 3.1 (branches/release_31 156863) 20120523
  configuration: --cc=clang --as=clang --extra-cflags=-I/usr/local/include --extra-ldflags=-L/usr/local/lib --disable-postproc --disable-indev=v4l2 --disable-indev=alsa --disable-indev=bktr -
-disable-indev=dshow --disable-indev=dv1394 --disable-indev=fbdev --disable-indev=jack --disable-indev=libcdio --disable-indev=libdc1394 --disable-indev=openal --disable-indev=pulse --disable
-indev=sndio --disable-indev=vfwcap --disable-outdev=sndio --disable-outdev=alsa --disable-outdev=sdl --disable-outdev=caca --disable-outdev=xv --disable-ffplay --disable-ffserver --disable-d
oc --enable-gpl --disable-static --disable-debug --enable-shared --enable-libschroedinger --enable-libopenjpeg --enable-libfreetype --enable-libmodplug --enable-libmp3lame --enable-libtwolame
 --enable-libx264 --enable-nonfree --enable-openssl --enable-x11grab --samples=../fate-suite
  libavutil      52. 40.100 / 52. 40.100
  libavcodec     55. 19.100 / 55. 19.100
  libavformat    55. 12.102 / 55. 12.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 81.103 /  3. 81.103
  libswscale      2.  4.100 /  2.  4.100
  libswresample   0. 17.103 /  0. 17.103
[dca @ 0x2a100400] Not a valid DCA frame
[dca @ 0x2a100400] error decoding block
[dca @ 0x2a100400] Invalid bit allocation index
[dca @ 0x2a100400] error decoding block
[dca @ 0x2a100400] Didn't get subframe DSYNC
[dca @ 0x2a100400] error decoding block
...
    Last message repeated 3 times
[dca @ 0x2a100400] Didn't get subframe DSYNC
[dca @ 0x2a100400] error decoding block
[wav @ 0x2a0ee100] decoding for stream 0 failed
[wav @ 0x2a0ee100] Could not find codec parameters for stream 0 (Audio: dts ([1][0][0][0] / 0x0001), 192000 Hz, 2 channels, fltp, 0 kb/s): no decodable DTS frames
Consider increasing the value for the 'analyzeduration' and 'probesize' options
steps-stereo-16b-44khz.wav: Operation not permitted

Attachments (1)

steps-stereo-16b-44khz.wav (361.8 KB) - added by richardpl 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by richardpl

comment:1 Changed 3 years ago by richardpl

  • Status changed from new to open

comment:2 Changed 3 years ago by cehoyos

  • Keywords wav added
  • Priority changed from normal to important
  • Reproduced by developer unset

Looks important.

comment:3 Changed 3 years ago by richardpl

  • Reproduced by developer set

comment:4 Changed 3 years ago by cehoyos

  • Reproduced by developer unset

comment:5 Changed 3 years ago by cehoyos

  • Keywords regression dca probe added
  • Reproduced by developer set

Regression since 697b476.

comment:6 follow-up: Changed 3 years ago by richardpl

  • Description modified (diff)

comment:7 in reply to: ↑ 6 ; follow-up: Changed 3 years ago by cehoyos

Replying to richardpl:

Your name isn't Richard?

How is this ticket ffprobe-related?

comment:8 in reply to: ↑ 7 Changed 3 years ago by richardpl

Replying to cehoyos:

Replying to richardpl:

Your name isn't Richard?

How is this ticket ffprobe-related?

My name is Khan.
Ticket is not ffprobe related.

Do you have more unrelated questions?

comment:9 Changed 3 years ago by cehoyos

Sorry for not adding a workaround originally.
This is not the correct workaround (suggested elsewhere):
ffmpeg -f s16le ...

The following works as expected:
$ ffmpeg -acodec pcm_s16le -i steps-stereo-16b-44khz.wav

comment:10 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.