Opened 6 years ago

Closed 5 years ago

Last modified 5 months ago

#2799 closed enhancement (fixed)

No support for cmyk jpeg

Reported by: cyril Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: mjpeg cmyk
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
FFmpeg doesn't support jpg using the CMYK colorspace.

How to reproduce:
Get the sample @ http://towerofbabel.free.fr/test/SLW_LOGO_CMYK.jpg

% ffplay  SLW_LOGO_CMYK.jpg
ffplay version N-54691-g7f4a1fd Copyright (c) 2003-2013 the FFmpeg developers
  built on Jul 12 2013 16:31:48 with gcc 4.7.3 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-
amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --
enable-libxvid --enable-zlib
  libavutil      52. 39.100 / 52. 39.100
  libavcodec     55. 18.102 / 55. 18.102
  libavformat    55. 12.102 / 55. 12.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 80.101 /  3. 80.101
  libswscale      2.  3.100 /  2.  3.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
Unhandled pixel format 0x11111111  0KB vq=    0KB sq=    0B f=0/0
[image2 @ 00000000024c1960] decoding for stream 0 failed
[image2 @ 00000000024c1960] Could not find codec parameters for stream 0 (Video:
 mjpeg, 4776x2033): unspecified pixel format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
SLW_LOGO_CMYK.jpg: could not find codec parameters

Attachments (1)

Channel_digital_image_CMYK_color.jpg (714.5 KB) - added by cehoyos 6 years ago.
CMYK sample from wikipedia

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFplay to avcodec
  • Keywords mjpeg added
  • Reproduced by developer set
  • Status changed from new to open

FFmpeg originally correctly reported that it cannot decode the image, now an image with incorrect colours and a completely transparent alpha layer is decoded without any warning.

$ ffmpeg -i SLW_LOGO_CMYK.jpg
ffmpeg version N-54924-g5156d48 Copyright (c) 2000-2013 the FFmpeg developers
  built on Jul 25 2013 09:01:09 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 40.100 / 52. 40.100
  libavcodec     55. 19.100 / 55. 19.100
  libavformat    55. 12.102 / 55. 12.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 81.103 /  3. 81.103
  libswscale      2.  4.100 /  2.  4.100
  libswresample   0. 17.103 /  0. 17.103
  libpostproc    52.  3.100 / 52.  3.100
Input #0, image2, from 'SLW_LOGO_CMYK.jpg':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: mjpeg, yuva444p, 4776x2033, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Changed 6 years ago by cehoyos

CMYK sample from wikipedia

comment:2 Changed 5 years ago by cehoyos

Ticket #3424 contains another sample.

comment:3 Changed 5 years ago by cehoyos

  • Priority changed from normal to wish
  • Type changed from defect to enhancement

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

The original sample and the sample from ticket #3424 work fine since a05635ee
I will open a new ticket - #3426 - for the remaining sample.

Last edited 5 years ago by cehoyos (previous) (diff)

comment:5 Changed 5 months ago by cehoyos

  • Keywords cmyk added
Note: See TracTickets for help on using tickets.