Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2751 closed defect (needs_more_info)

libavformat demuxes the rest of the whole file at once when reading a packet from a mpegps stream, genpts is enabled, and there are timestamp jumps

Reported by: gjdfgh Owned by:
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

No testcase. No console output. Nothing.

Sorry for the low quality bug report, but I thought I'd report it anyway.

Change History (5)

comment:1 Changed 4 years ago by gjdfgh

Maybe I should explain why it's hard to produce a test case. This happens when using libavformat on the libdvdread stream output when playing a commercial DVD. A small sample won't demonstrate the freeze, because libavformat will reach EOF quickly. Also, a freeze doesn't really have any interesting output. So I'm not sure what to do.

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please do not hesitate to reopen this ticket if you can provide a reproducible test case and / or a sample.

comment:3 Changed 4 years ago by michael

avformat at debug log level prints for example "Statistics: 3985552 bytes read, 2 seeks"
You should be able to make a testcase based on that

comment:4 Changed 4 years ago by cehoyos

Is the problem reproducible with the sample from ticket #1438? (If this issue is not a duplicate of ticket #1438.)

comment:5 Changed 4 years ago by gjdfgh

Possibly, but I'm not sure. At least in this case it doesn't try to read endlessly after encountering the reset, but stops before EOF.

Note: See TracTickets for help on using tickets.