Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2688 closed defect (fixed)

mp3 autodetection fails

Reported by: jlazkano Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mp3 idcin regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hello, I start this bug in the mythtv mail-list, this is my problem:

I have lots of MP3 files and all works well except few files. This is
the frontend output when the file fails:

Jun 17 22:57:29 telemedia mythfrontend[7958]: N CoreContext?
mythmainwindow.cpp:2601 (PauseIdleTimer?) Suspending idle timer
Jun 17 22:57:30 telemedia mythfrontend[7958]: N CoreContext?
mythmainwindow.cpp:2606 (PauseIdleTimer?) Resuming idle timer
Jun 17 22:57:30 telemedia mythfrontend[7958]: N CoreContext?
mythmainwindow.cpp:2606 (PauseIdleTimer?) Resuming idle timer
Jun 17 22:57:30 telemedia mythfrontend[7958]: E CoreContext?
musiccommon.cpp:1253 (customEvent) Error del descodificador.
AVCodecContext tells us 0 channels are available, this is bad,
bailing.

This is the song that fails:
https://dl.dropboxusercontent.com/u/1541853/A%20New%20Day%20Has%20Come.mp3

The song works well with other players, could someone help with this problem?

Regards.

Change History (5)

comment:1 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mp3 idcin regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

For future tickets:
Please always provide a failing ffmpeg command line together with the complete, uncut console output.

Regression since 6612d8c

$ ffmpeg -loglevel 99 -i A\ New\ Day\ Has\ Come.mp3
ffmpeg version N-54112-g4110828 Copyright (c) 2000-2013 the FFmpeg developers
  built on Jun 19 2013 17:14:59 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 37.101 / 52. 37.101
  libavcodec     55. 16.100 / 55. 16.100
  libavformat    55.  9.100 / 55.  9.100
  libavdevice    55.  2.100 / 55.  2.100
  libavfilter     3. 77.101 /  3. 77.101
  libswscale      2.  3.100 /  2.  3.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ... matched as input file with argument 'A New Day Has Come.mp3'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option loglevel (set logging level) with argument 99.
Successfully parsed a group of options.
Parsing a group of options: input file A New Day Has Come.mp3.
Successfully parsed a group of options.
Opening an input file: A New Day Has Come.mp3.
[idcin @ 0x2514020] Format idcin probed with size=262144 and score=50
[idcin @ 0x2514020] id3v2 ver:3 flags:00 len:145020
[idcin @ 0x2514020] invalid bytes per sample: 0
[AVIOContext @ 0x251c6e0] Statistics: 262144 bytes read, 0 seeks
A New Day Has Come.mp3: Invalid data found when processing input

comment:2 Changed 3 years ago by cehoyos

  • Summary changed from codec problem to mp3 autodetection fails

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed, thank you for the report!

comment:4 follow-up: Changed 3 years ago by jyavenard

Any chance to get this fix back ported to earlier stable release? Been broken since 1.0

comment:5 in reply to: ↑ 4 Changed 3 years ago by cehoyos

Replying to jyavenard:

Any chance to get this fix back ported to earlier stable release?

In which current release series does it not work?

Been broken since 1.0

It had been broken since 0.7.

Last edited 3 years ago by cehoyos (previous) (diff)
Note: See TracTickets for help on using tickets.