Opened 4 years ago

Closed 13 months ago

#2665 closed defect (needs_more_info)

AV_PICTURE_TYPE_NONE is returned for multiple slice H264 frames

Reported by: Gibraltar Owned by:
Priority: normal Component: undetermined
Version: 1.1.5 Keywords: h264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
An incorrect AVPictureType is returned during demux for two slice per H264 encoded streams. When calling av_read_frame to demux a packet from a Mpeg-2 H264 stream, the returned avpacket AVPictureType is AV_PICTURE_TYPE_NONE in the case where it should be AV_PICTURE_TYPE_I.
This only happens when the H264 frames has two slices per frame as shown in attached image.
How to reproduce:
Demux an H264 I frame when the H264 is two slices per frame.

Attachments (3)

New Bitmap Image.bmp (1.2 MB) - added by Gibraltar 4 years ago.
Stream that causes av_read_frame to return unknown packet type
MultiSliceVideoSample.ts (1.3 MB) - added by Gibraltar 4 years ago.
Sample file
ffprobeout.bmp (1.5 MB) - added by Gibraltar 4 years ago.
ffprobe errors related to iframe and missing pps/sps info.

Change History (8)

Changed 4 years ago by Gibraltar

Stream that causes av_read_frame to return unknown packet type

comment:1 Changed 4 years ago by cehoyos

  • Component changed from avutil to undetermined
  • Keywords h264 added

Please test current git head, please provide a sample and please explain how to reproduce.

Changed 4 years ago by Gibraltar

Sample file

comment:2 Changed 4 years ago by Gibraltar

Sample added, issue appears with Git, trying to use ffmpeg.exe to reproduce.

Changed 4 years ago by Gibraltar

ffprobe errors related to iframe and missing pps/sps info.

comment:3 Changed 4 years ago by Gibraltar

Using ffprobe.exe on the sample shows non-existing PPS 0 referenced even though the PPS packet with id 0 exists. Please see ffprobe screenshot.

comment:4 Changed 4 years ago by cehoyos

Please test current git head and please do not post screenshots, instead simply copy the console content (command line and output) into the ticket.
If the problem is reproducible with ffmpeg (the application), please provide ffmpeg command line and console output, only post ffprobe output for ffprobe-specific problems.

I am not sure I understand the overall issue: You originally reported (if I understood correctly) that ffmpeg does not recognize the frame type correctly, now you write about warnings in the console output: These warnings are normal for transport streams, you generally cannot cut such streams on (I-) frame boundaries, the warnings are produced by frames before the first keyframe.
Are you maybe searching for the showinfo filter?

comment:5 Changed 13 months ago by richardpl

  • Resolution set to needs_more_info
  • Status changed from new to closed

Unclear bug report.

Note: See TracTickets for help on using tickets.