Opened 4 years ago

Closed 4 years ago

#2647 closed defect (fixed)

No counter when playing back shorten with ffplay

Reported by: cehoyos Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords: shorten regression
Cc: cus@passwd.hu Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

As reported by ami_stuff in ticket #1874 ffplay shows "nan" when playing back shorten, this is a regression since 26c208c

$ time ./ffplay fate-suite/lossless-audio/luckynight-partial.shn
ffplay version N-53877-g3554238 Copyright (c) 2003-2013 the FFmpeg developers
  built on Jun  6 2013 20:05:06 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 35.100 / 52. 35.100
  libavcodec     55. 15.100 / 55. 15.100
  libavformat    55.  8.102 / 55.  8.102
  libavdevice    55.  2.100 / 55.  2.100
  libavfilter     3. 75.101 /  3. 75.101
  libswscale      2.  3.100 /  2.  3.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
Input #0, shn, from 'fate-suite/lossless-audio/luckynight-partial.shn':
  Duration: N/A, start: 0.000000, bitrate: N/A
    Stream #0:0: Audio: shorten, 44100 Hz, 2 channels, s16p
    nan M-A:    nan fd=   0 aq=    6KB vq=    0KB sq=    0B f=0/0

real    0m8.199s
user    0m0.189s
sys     0m0.125s

Change History (2)

comment:1 Changed 4 years ago by cus

  • Analyzed by developer set
  • Cc cus@passwd.hu added

This is because the avpacket audio pts-es are all AV_NOPTS_VALUE-s, therefore there is no way to know the real audio pts-es.

comment:2 Changed 4 years ago by cus

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.