Opened 5 years ago

Closed 13 months ago

#2584 closed enhancement (fixed)

Allow video loop on file protocol @ ffmpeg

Reported by: jbvsmo Owned by:
Priority: wish Component: ffmpeg
Version: git-master Keywords: loop
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

On ffmpeg, the "-loop" input option currently only works for image2 format and not for videos using the file protocol.
This is somewhat surprising once ffplay can loop over a video file with the "-loop" option. Also, the "concat" demuxer should allow this behavior without much work.

The expected usage should be the same as ffplay (the amount of loops, being 0 == infinite) and not like image2 (true/false).

$ ffmpeg -loop 10 -i input.avi ... output

The "movie" filter could also take advantage of that feature.

related: issue #729, issue #1799

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to avformat

comment:2 Changed 13 months ago by cehoyos

  • Component changed from avformat to ffmpeg
  • Resolution set to fixed
  • Status changed from new to closed

Option -stream_loop for ffmpeg exists since dbb03b8e, implemented by Alexandra Hájková.

Note: See TracTickets for help on using tickets.