Opened 5 years ago

Closed 5 years ago

#2477 closed defect (fixed)

libswscale make error (--disable-optimization)

Reported by: Andrew Owned by:
Priority: minor Component: swscale
Version: git-master Keywords: build regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

$ ./configure --disable-optimization
In file included from libswscale/x86/rgb2rgb.c:98:
libswscale/x86/rgb2rgb_template.c: In function ‘rgb24toyv12_MMX’:
libswscale/x86/rgb2rgb_template.c:1695: error: can't find a register in class ‘GENERAL_REGS’ while reloading ‘asm’
libswscale/x86/rgb2rgb_template.c:1695: error: ‘asm’ operand has impossible constraints
make: *** [libswscale/x86/rgb2rgb.o] Error 1

% ./version.sh
N-52233-gee94362

% gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.4.5-8' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --with-arch-32=i586 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.5 (Debian 4.4.5-8) 

config.h - included.

Attachments (3)

config.h (46.0 KB) - added by Andrew 5 years ago.
config.log (209.2 KB) - added by Andrew 5 years ago.
config.asm (45.5 KB) - added by Andrew 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Andrew

Changed 5 years ago by Andrew

Changed 5 years ago by Andrew

comment:1 Changed 5 years ago by cehoyos

  • Keywords build regression added; swscale make error removed
  • Reproduced by developer set
  • Status changed from new to open

Regression since 3950236, patch sent but see ticket #1932 for a reason why this may not be fixed.
(On some architectures, --disable-optimizations needs --disable-asm)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in git head, thank you for the report.

Note: See TracTickets for help on using tickets.