Opened 5 years ago

Closed 5 years ago

#2466 closed defect (fixed)

Matroska testfile test7.mkv fails again

Reported by: cehoyos Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mkv regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

Ticket #545, fixed in d493170, broken since 3bbf3f7
Source file is test7.mkv in https://sourceforge.net/projects/matroska/files/test_files/matroska_test_w1_1.zip/download
Expected output file length is approximately 37 seconds:

$ ffmpeg -i test7.mkv -qscale 2 -an out.avi
ffmpeg version N-52052-gdcea585 Copyright (c) 2000-2013 the FFmpeg developers
  built on Apr 13 2013 09:34:10 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 26.100 / 52. 26.100
  libavcodec     55.  2.100 / 55.  2.100
  libavformat    55.  2.100 / 55.  2.100
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 53.101 /  3. 53.101
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
[matroska,webm @ 0x1be5f80] Unknown entry 0x4001
Input #0, matroska,webm, from 'test7.mkv':
  Metadata:
    creation_time   : 2010-08-21 17:00:23
    TITLE           : Big Buck Bunny - test 7
    DATE_RELEASED   : 2010
    COMMENT         : Matroska Validation File 7, junk elements are present at the beggining or end of clusters, the parser should skip it. There is also a damaged element at 451418
  Duration: 00:00:37.04, start: 0.000000, bitrate: 4718 kb/s
    Stream #0:0: Video: h264 (Main), yuv420p, 1024x576, SAR 1:1 DAR 16:9, 24 fps, 24 tbr, 1k tbn, 2k tbc
    Stream #0:1: Audio: aac, 48000 Hz, stereo, fltp
Please use -q:a or -q:v, -qscale is ambiguous
Output #0, avi, to 'out.avi':
  Metadata:
    ICMT            : Matroska Validation File 7, junk elements are present at the beggining or end of clusters, the parser should skip it. There is also a damaged element at 451418
    INAM            : Big Buck Bunny - test 7
    DATE_RELEASED   : 2010
    ISFT            : Lavf55.2.100
    Stream #0:0: Video: mpeg4 (FMP4 / 0x34504D46), yuv420p, 1024x576 [SAR 1:1 DAR 16:9], q=2-31, 200 kb/s, 24 tbn, 24 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (h264 -> mpeg4)
Press [q] to stop, [?] for help
[matroska,webm @ 0x1be5f80] Invalid track number 87
[matroska,webm @ 0x1be5f80] Invalid stream 87 or size 31
frame=   24 fps=0.0 q=2.0 Lsize=     684kB time=00:00:01.00 bitrate=5605.7kbits/s
video:678kB audio:0kB subtitle:0 global headers:0kB muxing overhead 0.943005%

Change History (5)

comment:1 Changed 5 years ago by reimar

Could someone bisect which change broke it? The code from 545 is still there and should be working.
In addition, this sample file should be added to the FATE tests.

comment:2 in reply to: ↑ description Changed 5 years ago by cehoyos

Replying to cehoyos:

Ticket #545, fixed in d493170, broken since 88ee2aa

@Reimar: How can I improve the wording above?

comment:3 Changed 5 years ago by cehoyos

Regression since 3bbf3f7 - sorry about the useless spam above!

comment:4 Changed 5 years ago by cehoyos

  • Description modified (diff)

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Reimar in 762d433

Note: See TracTickets for help on using tickets.