Opened 6 years ago

Closed 5 years ago

#245 closed defect (fixed)

bext display error for codingHistory with line breaks

Reported by: dericed Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: bext metadata wav bwf
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

codingHistory displays correctly with 'ffmpeg -i' if it uses 0x0A line breaks

  Metadata:
    originator      : US, NARA
    origination_date: 2009-10-20
    origination_time: 07:32:32
    time_reference  : 0
    coding_history  : A=PCM,F=44100,W=16,M=stereo

but if codingHistory uses only 0x0D line breaks then only the last line is displayed

  Metadata:
    description     : CartChunk.org linear PCM sample file containing 'bext' and 'cart' chunks
    originator      : US, NARA
    originator_reference: CartChunk.org
    origination_date: 2001/09/13
    origination_time: 07:50:05
    time_reference  : 0
A=PCM,F=32000,W=16,M=stereo,T=Orban AUDICY SRCreo,T=Orban AUDICY EDIT

Attachments (1)

Metadata Test.wav (870.3 KB) - added by dericed 6 years ago.
wav file with bext, codingHistory with 0x0D line returns

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by dericed

wav file with bext, codingHistory with 0x0D line returns

comment:1 Changed 6 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Status changed from new to open

Complete, uncut output of ffmpeg missing (this is needed for all non-build problems, it should of course be cut if lines are repeated, but this is not the case here afaict).

comment:2 Changed 6 years ago by dericed

complete output

ffmpeg -i Metadata\ Test.wav
ffmpeg version git-N-30260-g39e4206, Copyright (c) 2000-2011 the FFmpeg developers
  built on May 26 2011 08:59:53 with gcc 4.2.1 (Apple Inc. build 5666) (dot 3)
  configuration: --enable-gpl --enable-libfreetype --enable-frei0r --enable-libx264 --enable-shared
  libavutil    51.  2. 2 / 51.  2. 2
  libavcodec   53.  6. 0 / 53.  6. 0
  libavformat  53.  2. 0 / 53.  2. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2. 11. 0 /  2. 11. 0
  libswscale    0. 14. 0 /  0. 14. 0
  libpostproc  51.  2. 0 / 51.  2. 0
Input #0, wav, from 'Metadata Test.wav':
  Metadata:
    description     : Description
    originator      : Originator
    originator_reference: Originator Reference
    origination_date: 2011-05-25
    origination_time: 15:42:36
    time_reference  : 164184300
    umid            : 0xFFFFFFFFAAAABBBBCCCC01234567890100000000000000000000000000000000
A=PCM,F=22050,W=16,M=stereo,T=down-sampled with ffmpeg
  Duration: 00:00:05.00, bitrate: 1425 kb/s
    Stream #0.0: Audio: pcm_s16le, 44100 Hz, 2 channels, s16, 1411 kb/s
At least one output file must be specified

comment:3 Changed 6 years ago by Tjoppen

Only the last line is displayed because carriage returns are used (presumably the file is from a Mac). In other words, this is a matter of presentation. There are a number of ways to solve this I suppose.
One way could be to scan through each metadata value before display, count the lines then display each one by indenting with spaces. Any other ideas?
In the meantime, are you able to change the delimiter in any way?

comment:4 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

Fixed locally will be in the next push

Note: See TracTickets for help on using tickets.