Opened 7 years ago

Closed 4 years ago

Last modified 3 years ago

#24 closed enhancement (wontfix)

Error message needed when enabling drawtext filter without libfreetype

Reported by: xj25vm Owned by:
Priority: normal Component: build system
Version: git Keywords: libfreetype drawtext
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It would be really helpful if the configure script would issue an error message when trying to do "--enable-filter=drawtext" without adding "--enable-libfreetype". At the moment, there is no error message, and the drawtext filter doesn't get enabled.

The documentation of the drawtext filter does mention then libfreetype is needed - but it would be much more helpful if the configure script would do this check. Otherwise one would have no idea why the filter silently refuses to enable with no error message.

Change History (3)

comment:1 Changed 7 years ago by michael

  • Component changed from FFmpeg to build system
  • Owner michael deleted
  • Status changed from new to open

comment:2 Changed 4 years ago by cehoyos

  • Keywords configure filter removed
  • Resolution set to wontfix
  • Status changed from open to closed

Afaict, this is not how FFmpeg's configure script works:
--enable-filter=drawtext normally has no meaning because it is the default (drawtext will be enabled if the dependencies are fulfilled and it was not disabled), but since drawtext depends on an external library (like the flashsv decoder or the matroska demuxer), it will only be compiled if --enable-libfreetype was added as an option.

Note that the following works as expected / is needed if you want the drawtext filter:
$ ./configure --disable-filters --enable-libfreetype --enable-filter=drawtext

comment:3 Changed 3 years ago by illumilore

I see. Would it be possible to change the error message when drawtext is used but not able to run to alert the user that the freetype option is needed when configuring?

Note: See TracTickets for help on using tickets.