Opened 6 years ago

Closed 6 years ago

#2373 closed defect (invalid)

hqdn3d produces banding

Reported by: sun Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: hqdn3d
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: the temporal denoiser of the hqdn3d filter produces banding. This is mostly noticeable on fine gradients with low luma value and some noise. Seems that the filter tries to clamp a pixel's value over the time.
How to reproduce:
I have uploaded a short example raw file that will show banding in the thicker parts of the tree. There is not much noise, but this shows that some gradients get destroyed by the filter.

http://www.mediafire.com/?dyy3knfcbmh4ftr

% ffmpeg -i input -vcodec dnxhd -acodec copy -vb 120000k -vf hqdn3d=0:0:8:8 output
ffmpeg version N-37943-gc87c2d0
built on N-37943-gc87c2d0

Change History (3)

comment:1 Changed 6 years ago by cehoyos

  • Keywords hqdn3d added

Please provide the complete, uncut console output of your failing command.

comment:2 follow-up: Changed 6 years ago by sun

I have researched a bit and found out that the hdn3d effects produces banding due to the way it works. So do it's frei0r and mplayer implementations. I guess the bug can be closed because it is not an ffmpeg only issue and seems to be known by users.

comment:3 in reply to: ↑ 2 Changed 6 years ago by michael

  • Resolution set to invalid
  • Status changed from new to closed

Replying to sun:

I have researched a bit and found out that the hdn3d effects produces banding due to the way it works. So do it's frei0r and mplayer implementations. I guess the bug can be closed because it is not an ffmpeg only issue and seems to be known by users.

Ok, closed

Note: See TracTickets for help on using tickets.