Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2226 closed enhancement (wontfix)

FFprobe should output to stdout

Reported by: evilsoup Owned by:
Priority: wish Component: ffprobe
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

At the moment, all the tools output the text information to stderr. Obviously, for ffmpeg this is necessary; but ffprobe doesn't output A/V data, only text, so this behaviour doesn't serve any purpose.

The current workaround (for regexing the output etc) is to use ffprobe input.file 2>&1. This isn't particularly onerous, but it would be nicer to have ffprobe output to stdout by default. Changing it also wouldn't break any pre-existing scripts that people are using with the current workaround, either.

Change History (4)

comment:1 follow-up: Changed 5 years ago by Cigaes

AFAICS, the output of ffprobe goes to stdout. The licence boilerplate and input format dump are to stderr, but they are not meant to be parseable.

comment:2 in reply to: ↑ 1 Changed 5 years ago by saste

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to Cigaes:

AFAICS, the output of ffprobe goes to stdout. The licence boilerplate and input format dump are to stderr, but they are not meant to be parseable.

Closing as WONTFIX, for the exact reason explained above (parsing output which is not meant to be parseable defeats the whole design purpose of ffprobe).

comment:3 follow-up: Changed 5 years ago by cehoyos

  • Keywords ffprobe stdout stderr removed
  • Resolution changed from wontfix to fixed

Do I understand correctly that this actually is not "wontfix" but "worksforme"?
(I did not test.)

comment:4 in reply to: ↑ 3 Changed 5 years ago by saste

  • Resolution changed from fixed to wontfix

Replying to cehoyos:

Do I understand correctly that this actually is not "wontfix" but "worksforme"?
(I did not test.)

It is WONTFIX, with a slight declination towards INVALID, since the proposal was to implement an anti-feature (e.g. you don't want to parse unparsable output when parsing the regular - parser friendly - output which goes to stdout), and yes it would break all the scripts which parse the current output.

Note that the title of the ticket is misleading, since ffprobe output currently *goes* to stdout, but for the configuration/version blurb which goes to stderr (and is not meant to be parsable).

Note: See TracTickets for help on using tickets.