Opened 5 years ago

Closed 13 months ago

#2178 closed enhancement (needs_more_info)

audio denoise filter

Reported by: valley_rain Owned by:
Priority: wish Component: avfilter
Version: git-master Keywords: denoise
Cc: gajjanagadde@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffplay -f oss -i /dev/dsp
ffmpeg version git-2012-12-14-5c78a81
built on ubuntu

Change History (6)

comment:1 Changed 5 years ago by valley_rain

audio denoise

comment:2 follow-up: Changed 5 years ago by cehoyos

  • Component changed from FFplay to avfilter
  • Keywords denoise added
  • Priority changed from normal to wish
  • Type changed from task to enhancement

Since at least for me it is not entirely clear if a "denoise filter" is something reasonably defined: Could you either add some explanation what the filter should do or point to a documentation (or an example filter)?

comment:3 in reply to: ↑ 2 Changed 5 years ago by valley_rain

For example,ffmpeg filter:“aformat”.
Convert the input audio to one of the specified formats.

But I want one filter which can reduce the audio noise,eliminate the broken sound and echo.

The input audio is captured from the pc's microphone,and the output audio is very clear.

If you want to know all the filters of the ffmpeg,you can use "ffmpeg -filters".

comment:4 Changed 2 years ago by gajjanag

It should be clear that such a general purpose filter cannot exist: one has to know what kind of noise you are looking for in order to filter it out. Different algorithms will work well against different kinds of noise.

A quick internet search will show a number of approaches taken for this. Do you want something like Audacity's approach set:
http://wiki.audacityteam.org/wiki/Noise_Reduction#Other_Techniques?

comment:5 Changed 2 years ago by gajjanag

  • Cc gajjanagadde@gmail.com added

comment:6 Changed 13 months ago by richardpl

  • Resolution set to needs_more_info
  • Status changed from new to closed

Feel free to reopen, once you provide input audio files with noise.

Note: See TracTickets for help on using tickets.