Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2051 closed defect (duplicate)

Video merging sinking issue

Reported by: elby Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: async flv nellymoser
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hi all,

We are trying to merge couple of videos.

Using code { ffmpeg -i input.flv -qscale:v 1 -y output.mpg }
then an issue occurred in audio / Video Sinking. ie the lips sink is not correct.

Attachments (3)

TestOrginal1.flv (425.2 KB ) - added by elby 9 years ago.
input file 1st
TestOrginal2.flv (1.8 MB ) - added by elby 9 years ago.
Input File 2
concat.txt (44 bytes ) - added by Carl Eugen Hoyos 9 years ago.

Change History (7)

comment:1 by Carl Eugen Hoyos, 9 years ago

Keywords: ffmpeg video merging removed
Priority: importantnormal

To make this a valid ticket, please provide the command line you are using together with the complete, uncut console output.
And please consider providing a sample that allows to reproduce the problem.

by elby, 9 years ago

Attachment: TestOrginal1.flv added

input file 1st

by elby, 9 years ago

Attachment: TestOrginal2.flv added

Input File 2

comment:2 by elby, 9 years ago

Hi all,
We are trying to merge couple of videos.
Using code { ffmpeg -i input1.flv -qscale:v 1 -y output1.mpg }

{ ffmpeg -i input2.flv -qscale:v 1 -y output2.mpg }

for join videos using

{ cat output1.mpg output2.mpg > indeterminate_all.mpg }

We got complete output using following code

{ ffmpeg -i indeterminate_all.mpg -qscale:v 2 completeoutput.avi }

then an issue occurred in audio / Video Sinking. ie the lips sink is not correct.

by Carl Eugen Hoyos, 9 years ago

Attachment: concat.txt added

comment:3 by Carl Eugen Hoyos, 9 years ago

Keywords: async flv nellymoser added
Resolution: duplicate
Status: newclosed

I believe this is a duplicate of ticket #1555 (and some issues on roundup), not a regression afaict.
Reproducible with:
$ ffmpeg -i TestOrginal1.flv -qscale 2 out1.avi

Works fine with -async 1:
$ ffmpeg -async 1 -i TestOrginal1.flv -qscale 2 out1async1.avi

The concatenation works here for example with the following command line:
$ ffmpeg -async 1 -f concat -i concat.txt -qscale 2 outdemuxer.avi

comment:4 by Carl Eugen Hoyos, 9 years ago

Here is another alternative (using the concat filter) that allows to concatenate the files and keep A/V sync (thanks to Clément Bœsch for the example):

$ ffmpeg -i TestOrginal1.flv -i TestOrginal2.flv -filter_complex '[0:0][0:1][1:0][1:1]concat=v=1:a=1[v],aresample=async=1[a]' -map [v] -map [a] -qscale 2 outfilter.avi

Or an equivalent shorter command line:

$ ffmpeg -i TestOrginal1.flv -i TestOrginal2.flv -filter_complex 'concat=a=1[v],aresample=async=1' -map [v] -qscale 2 outfiltershort.avi
Note: See TracTickets for help on using tickets.