Opened 6 years ago

Closed 5 years ago

#2036 closed defect (fixed)

AsyncTS filter non existent

Reported by: ramitbhalla Owned by:
Priority: minor Component: documentation
Version: git-master Keywords: asyncts
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: The asyncts filter doesn't exist in the default builds. Is this by design? According to the documentation this option doesn't appear to be deprecated.

How to reproduce:

ffmpeg.239-current -threads 0 -drc_scale 0.8 -y -i "test.ts" -ss 3 -vf yadif=0:-1,h
qdn3d,crop=1280:720:0:0,scale=720:400 -vcodec mpeg4 -vtag xvid -b 1800000 -f avi -flags +mv4+aic -g 300 -dts_delta_thres
hold 0 -acodec ac3 -ab 256k -ac 2 -af asyncts=compensate test.mp4
ffmpeg version N-46726-g2f74f8d Copyright (c) 2000-2012 the FFmpeg developers
  built on Nov 13 2012 19:29:51 with gcc 4.7.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runtime-cpudetect --enable-avisynth --enable
-bzlib --enable-frei0r --enable-libass --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enab
le-libgsm --enable-libmp3lame --enable-libnut --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroed
inger --enable-libspeex --enable-libtheora --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-li
bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52.  6.100 / 52.  6.100
  libavcodec     54. 71.100 / 54. 71.100
  libavformat    54. 36.100 / 54. 36.100
  libavdevice    54.  3.100 / 54.  3.100
  libavfilter     3. 23.100 /  3. 23.100
  libswscale      2.  1.102 /  2.  1.102
  libswresample   0. 16.100 /  0. 16.100
  libpostproc    52.  1.100 / 52.  1.100
[mpegts @ 021ff700] Adjusting PTS forward
    Last message repeated 76 times
Input #0, mpegts, from 'test.ts':
  Duration: 01:04:58.15, start: 1.400000, bitrate: 10731 kb/s
  Program 1
    Metadata:
      service_name    : WVLTDT (WVLT-DT)
      service_provider: WVLTDT
    Stream #0:0[0x100]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 59.94 fp
s, 59.94 tbr, 90k tbn, 119.88 tbc
    Stream #0:1[0x101]: Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, stereo, s16, 192 kb/s
Please use -b:a or -b:v, -b is ambiguous
[AVFilterGraph @ 03844a60] No such filter: 'asyncts'
Error opening filters!

I'm trying to use this option because the audio is drifting out of sync with the video slowly over an hour. At the end of the hour the converted file has a 5 second audio drift. The original TS file has perfect audio video sync right through. Any ideas?

Change History (4)

comment:1 in reply to: ↑ description Changed 6 years ago by cehoyos

Replying to ramitbhalla:

Summary of the bug: The asyncts filter doesn't exist in the default builds. Is this by design?

Yes, please use aresample.

[...]

I'm trying to use this option because the audio is drifting out of sync with the video slowly over an hour. At the end of the hour the converted file has a 5 second audio drift. The original TS file has perfect audio video sync right through. Any ideas?

Yes, please provide the sample and post your (minimal!) command line together with complete, uncut console output into a new ticket.

comment:2 Changed 6 years ago by ramitbhalla

I've solved the problem with the audio sync, that was due to the -ss coming after the -i which was causing the audio sync issue. I had reported that separately and hope it'll be fixed with the Dec 13th build once it's released by Zeronae.

Perhaps the documentation can be updated regarding asyncts being deprecated.

comment:3 Changed 6 years ago by cehoyos

  • Component changed from undetermined to documentation
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:4 Changed 5 years ago by cehoyos

  • Keywords asyncts added
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed.

Note: See TracTickets for help on using tickets.