Opened 5 years ago

Closed 5 years ago

#2022 closed defect (fixed)

DNxHD: Decode video returns wrong number of bytes

Reported by: maf Owned by:
Priority: minor Component: avcodec
Version: unspecified Keywords: DNxHD
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes


Summary of the bug:
Value returned from dnxhd_decode_frame() is wrong. It only returns half of the buffer consumed.

The problem is that buf_size is not decremented in 2nd field iteration. The solution would be to move line:

  buf_size -= ctx->cid_table->coding_unit_size;

two lines up (before if() ).

Change History (2)

comment:1 Changed 5 years ago by cehoyos

Please send patches to ffmpeg-devel, they usually receive more attention there.

comment:2 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.