Opened 5 years ago

Closed 5 years ago

#1985 closed enhancement (wontfix)

Looking for a way to convert MS Powerpoint presentations to video using FFmpeg

Reported by: vk5ztv Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Has someone considered (or tried) writing a decoder for MS Powerpoint presentations to be able to render them as video files using FFmpeg?

Ideally, it would render the slides with any embedded images, audio and slide transitions defined in the presentation; if not the actual fancy transitions (which I would think would require complex filters), at least a basic cross-fade using the timings defined in the presentation. Where there are no timings present, a sensible default should be chosen with an option to specify timing on the command line.

I would attempt this myself but what I know of C programming could fit on the back of a postage stamp.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined

comment:2 Changed 5 years ago by reimar

I think it's safe to say there is no way we will implement a PowerPoint? parser and renderer, huge projects like OpenOffice/LibreOffice? barely manage to get something working, there is no way we could do it.
Even more so since it just doesn't fit into the demuxer/decoder split that FFmpeg assumes.
If you want this feature, it would be more realistic to ask one of the Office suites to implement a "render/export to video" feature, possibly by using FFmpeg. Similar to what e.g. Blender provides.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.