Opened 5 years ago

Closed 5 years ago

#198 closed defect (invalid)

Video filters bug?

Reported by: burek Owned by: michael
Priority: minor Component: ffmpeg
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Hi,

While helping a guy to stack 'scale' and 'crop' video filters, we've encountered a possible bug, so I think it's better to report it, although I'm not sure if the duplicate of this report exist.

Anyway: "scale=-1:480,crop=iw-mod(iw,2):480" gives: No such filter: '2):480'

when
-vf "scale=-1:480,crop=iw-mod(iw,2):480"
is given, ffmpeg mistakes the comma in the parenthesis for the delimiter of video filters (or this is the intended behavior?)

however, the issue can be resolved with a workaround:
"scale=-1:480,crop=(iw-mod(iw\,2)):480"

Change History (1)

comment:1 Changed 5 years ago by saste

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from new to closed

Hi, this is the assumed behavior, since ',' is a special character in the filtergraph syntax, so you need to escape it.

This can be done either with:
crop='iw-mod(iw,2):480',...

or as you suggested:
crop=iw-mod(iw\,2):480,...

On the other hand I see this should be documented better, and maybe we should add some examples in the crop documentation (contributions in this area are welcome).

Note: See TracTickets for help on using tickets.