Opened 5 years ago

Closed 4 years ago

#1936 closed defect (fixed)

iff 8svx: autoexit works incorrectly

Reported by: ami_stuff Owned by: cus
Priority: normal Component: ffplay
Version: git-master Keywords: iff
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

http://samples.mplayerhq.hu/8svx/descargmp3.8svx

C:\>ffplay -autoexit descargmp3.8svx
ffplay version N-46726-g2f74f8d Copyright (c) 2003-2012 the FFmpeg developers
  built on Nov 13 2012 19:29:51 with gcc 4.7.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runt
ime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass -
-enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enab
le-libgsm --enable-libmp3lame --enable-libnut --enable-libopenjpeg --enable-libo
pus --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheo
ra --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-li
bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --ena
ble-zlib
  libavutil      52.  6.100 / 52.  6.100
  libavcodec     54. 71.100 / 54. 71.100
  libavformat    54. 36.100 / 54. 36.100
  libavdevice    54.  3.100 / 54.  3.100
  libavfilter     3. 23.100 /  3. 23.100
  libswscale      2.  1.102 /  2.  1.102
  libswresample   0. 16.100 /  0. 16.100
  libpostproc    52.  1.100 / 52.  1.100
[iff @ 02af0060] Estimating duration from bitrate, this may be inaccurate
Input #0, iff, from 'descargmp3.8svx':
  Metadata:
    title           : descargmp3.8svx
    comment         : Audition 4
  Duration: 00:00:03.16, bitrate: 176 kb/s
    Stream #0:0: Audio: pcm_s8_planar (8SVX / 0x58565338), 22095 Hz, mono, u8p,
176 kb/s
   0.09 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Change History (6)

comment:1 follow-up: Changed 5 years ago by cehoyos

  • Keywords iff added

Works fine here...

Do you see an error message with the following command line (there is an error message for the sample from ticket #1935)?
$ ffmpeg -i descargmp3.8svx -f null -

comment:2 in reply to: ↑ 1 Changed 5 years ago by ami_stuff

Replying to cehoyos:

Works fine here...

I mean the problem is that FFplay closes at 0.09 while the sampe have 3s of duration.

Do you see an error message with the following command line (there is an error message for the sample from ticket #1935)?
$ ffmpeg -i descargmp3.8svx -f null -

Yes, I see the error with bink file, but this must be a false positive since the same error happens with my own encoded file here which is not corrupted.

comment:3 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Sorry, I originally misunderstood the issue.

comment:4 Changed 5 years ago by richardpl

  • Component changed from undetermined to FFplay

comment:5 Changed 5 years ago by cus

  • Owner set to cus

comment:6 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Marton in 02fc61a

Note: See TracTickets for help on using tickets.