Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#1870 closed task (wontfix)

review merges from libav

Reported by: richardpl Owned by:
Priority: important Component: undetermined
Version: git-master Keywords:
Cc: gajjanagadde@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

There are numerous examples in commit history which points out that merging changes from libav is more and more not-trivial task.

Change History (4)

comment:1 Changed 5 years ago by saste

This was discussed before, and we realized that it would make the whole merging business impractical, considering that each review may take several days. So I'm for letting Michael do his merging work with no review, and then have some occasional flames about how things were merged.

Also there are some areas where the merges are not that simple because the two codebases diverged too much, in that case it is necessary the work of a dedicated maintainer to port the relevant changes.

Since this is a policy issue, should be discussed on the ML.

comment:2 Changed 2 years ago by gajjanag

  • Cc gajjanagadde@gmail.com added

It has been 3 years since this ticket has been opened, and I thus assume relevant discussion would have happened on the mailing list. In any case, in my opinion this should not be a ticket, or at the very least should not be at an "important" level. Since I am not a regular developer, I won't close this right away, but will leave this open for another few days and then close if there are no objections.

comment:3 Changed 2 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 2 years ago by richardpl

  • Resolution changed from invalid to wontfix
Note: See TracTickets for help on using tickets.