Opened 5 years ago

Closed 5 years ago

#1837 closed enhancement (fixed)

avformat_new_stream const correctness

Reported by: henniez Owned by:
Priority: normal Component: avformat
Version: 1.0 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

the function avformat_new_stream takes the AVCodec *c as a non const value. this can be changed to const because AVCodec is just use in a const manner.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

Patches are very welcome on ffmpeg-devel, you may attach them here, but they typically receive significantly lower attention.

This tracker should primarily be used for bugs (like for example: gcc 4.8 cannot optimise avformat_new_stream() because of a missing const), it is not really meant for suggestions what could be changed in the source code - the reasons are limited manpower combined with a sufficient number of open bugs and feature requests.

comment:2 Changed 5 years ago by richardpl

  • Resolution set to fixed
  • Status changed from new to closed

patch posted on mailing list.

Note: See TracTickets for help on using tickets.