Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1807 closed defect (fixed)

ffmpeg won't read raw DNxHD 1080p 10 bits file

Reported by: corco Owned by:
Priority: minor Component: avformat
Version: git-master Keywords: dnxhd
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

ffmpeg won't read raw DNxHD frames with CID 1235 (1080p 10bits). It reads every other CIDs without problems.

How to reproduce:

ffmpeg -v 9 -loglevel 99 -i dnxhd_cid_1235.dnxhd dnxhd_cid_1235 -vcodec copy dnxhd_cid_1235.mov

Output:
ffmpeg version N-45388-g0d002de Copyright (c) 2000-2012 the FFmpeg developers

built on Oct 12 2012 12:24:44 with gcc 4.7.2 (GCC)
configuration:
libavutil 51. 76.100 / 51. 76.100
libavcodec 54. 65.100 / 54. 65.100
libavformat 54. 32.100 / 54. 32.100
libavdevice 54. 3.100 / 54. 3.100
libavfilter 3. 19.102 / 3. 19.102
libswscale 2. 1.101 / 2. 1.101
libswresample 0. 16.100 / 0. 16.100

[AVIOContext @ 0x20f3980] Statistics: 1048576 bytes read, 0 seeks
/home/corco/Downloads/dnxhd/cid_1235.dnxhd: Invalid data found when processing input

Attachments (1)

dnxhd_cid_1235.dnxhd (1.8 MB) - added by corco 5 years ago.
Sample raw dnxhd 1080p 10bits (CID 1235) file

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by corco

Sample raw dnxhd 1080p 10bits (CID 1235) file

comment:1 follow-up: Changed 5 years ago by llogan

Git master seems to be able to decode it with the addition of "-f dnxhd" as an input option.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by corco

Replying to llogan:

Git master seems to be able to decode it with the addition of "-f dnxhd" as an input option.

Thank you! But why does it works with other DNxHD formats without the "-f dnxhd" flag?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by llogan

Sorry, I don't know why. Are you sure it's the same issue? If yes, show your ffmpeg command and the complete console output for the videos that continue to not work with "-f dnxhd". Also, I assume applying "-f dnxhd" should be default behaviour for .dnhxd and if it isn't perhaps a wish/enhancement is in order. If it is default I don't know why it doesn't apply it to the sample.

comment:4 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Reproduced by developer set
  • Status changed from new to open

Patch on mailing list.

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed.

comment:6 in reply to: ↑ 3 Changed 5 years ago by cehoyos

Replying to llogan:

Also, I assume applying "-f dnxhd" should be default behaviour for .dnhxd

This is luckily not how FFmpeg behaves (except for a few image formats).
If you have a sample that is not auto-detected correctly although it decodes correctly with -f, please share it!

Note: See TracTickets for help on using tickets.