Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1787 closed defect (invalid)

Losing Silent Audio When Converting From Nellymoser Produced By Flash Media Server Recording

Reported by: eric@twvending.com Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: nellymoser
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Summary of the bug:

Hi Developers!

I am trying to stitch together two videos that are recorded from a Flash Media Server.
Using AviSynth? and FFMpeg I'm able to accomplish this! ...But the audio doesn't
convert correctly. It's losing packets when converting the Nellymoser audio
to any other format. (Ex: Wav, Mp4, Mp3)

Example: I start with an .flv and convert the audio to .wav and the sound clip changes
from a duration of ~1:28 to a duration of ~0:35.

I have done some research and solved my issue by setting the microphone silence level on
the Adobe Flash object to 0, preventing null packets from being sent.
This was encoding the audio and including packets that did not contain enough data,
or something.

If there is any way to fix this issue that chops off the silent packets of a Nellymoser
encoded audio stream, you may want to consider adding it to the ffmpeg project.

How to reproduce:

ffmpeg -i "E:\Frameserver\outputaudio.flv" "E:\Frameserver\outputaudio.wav"

ffmpeg version used:
ffmpeg version N-44727-gbbe9fe4 Copyright (c) 2000-2012 the FFmpeg developers
  built on Sep 24 2012 16:51:07 with gcc 4.7.1 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runt
ime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass -
-enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-l
ibfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopenj
peg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheo
ra --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-li
bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --ena
ble-zlib

Attachments (1)

1_1349110964561.flv (2.0 MB) - added by eric@twvending.com 5 years ago.
Nellymoser with silence

Change History (4)

Changed 5 years ago by eric@twvending.com

Nellymoser with silence

comment:1 Changed 5 years ago by saste

  • Analyzed by developer set
  • Component changed from undetermined to FFmpeg
  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from new to closed

Audio tracks with gaps need extra care. Filling the gaps requires the intervention of an audio filter. aresample can act as audio-gap filler, for example using the command:

ffmpeg -i IN.flv -af aresample=min_comp=0.001:min_hard_comp=0.100000 -y OUT.wav

Proper documentation for libswresample/aresample is a work in progress.

Please reopen the ticket if you're not satisfied with this answer.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords nellymoser added; Nellymoser Audio Losing Duration Flash Media Server removed

comment:3 Changed 5 years ago by eric@twvending.com

It looks like the filter works on my problem audio file. Thanks so much for the information! I will update if I run into any file that appears to lose chunks in a similar fashion.

Thank you,

-Eric Bloms

Note: See TracTickets for help on using tickets.