Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1765 closed defect (invalid)

Cannot build FFMPEG bundled with MPlayer ("File format not recognized")

Reported by: wknauf Owned by:
Priority: normal Component: build system
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I try to build FFMPEG which is downloaded as part of a MPlayer build.

The error is (during "make" of MPlayer):

cc -MD -MP -Wundef -Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundant-decls -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Werror-implicit-function-declaration -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -Ilibdvdread4 -I. -Iffmpeg  -D_REENTRANT  -I/usr/include/freetype2 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14   -c -o osdep/shmem.o osdep/shmem.c
make -C ffmpeg libpostproc/libpostproc.a
make[1]: Entering directory `/home/myuser/Arbeitsfläche/mplayer-export-2012-09-20/ffmpeg'
CC      libpostproc/postprocess.o
AR      libpostproc/libpostproc.a
ar: libpostproc/postprocess.o: File format not recognized
make[1]: *** [libpostproc/libpostproc.a] Error 1
make[1]: Leaving directory `/home/myuser/Arbeitsfläche/mplayer-export-2012-09-20/ffmpeg'
make: *** [ffmpeg/libpostproc/libpostproc.a] Fehler 2

"configure" of MPlayer downloaded the latest FFMPEG sources (I hope ;-)), which means: 2012-09-25 21:00

My system is OpenSuse? 12.2 x64.

Probably you need more details about my system, but I'm quite a Linux noob, sorry.

Change History (6)

comment:1 Changed 7 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Please report MPlayer build problems on mplayer-users.

comment:2 Changed 7 years ago by reimar

"File format not recognized" during compilation means that the file got corrupted, usually due to aborting the compiler (or it crashing) while it was in the middle of compiling the file.
Deleting the file (or better starting the compilation from scratch via "make clean" or "make distclean") solves it.

comment:3 Changed 7 years ago by wknauf

nope, same error happens after make clean, make distclean. I updated the src archive from today.

Shall I continue this in the mplayer mailinglist anyway?

comment:4 Changed 7 years ago by cehoyos

Please report MPlayer build problems on mplayer-users, do not forget to confirm there that you did something similar to "make distclean && svn up && ./configure && make".

comment:5 follow-up: Changed 7 years ago by wknauf

Deleting the old mplayer source dir and starting with a clean package (and not running "make" as root) made it work. Don't know what went wrong...

Thanks for the help, guys!

comment:6 in reply to: ↑ 5 Changed 7 years ago by cehoyos

Replying to wknauf:

Don't know what went wrong...

Your MPlayer configure file was outdated.

Please report future problems at the appropriate place (mplayer-users if you have problems with MPlayer, ffmpeg-user or trac for FFmpeg-problems) and you will get support.

Note: See TracTickets for help on using tickets.