Opened 5 years ago

Closed 5 years ago

#173 closed defect (fixed)

ffplay jpeg2000 regression

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Please first apply the patch attached to this ticket and try to display j2k file from here:

http://www.openjpeg.org/samples/Bretagne1.j2k

I get only black screen.

with the result of conversion

ffmpeg -i Bretagne1.j2k out.bmp

ffplay out.bmp

everything works correctly

so seems like regression

ffplay Bretagne1.j2k            
ffplay version git-b9e6084, Copyright (c) 2003-2011 the FFmpeg developers
  built on May  8 2011 16:30:48 with gcc 4.5.0
  configuration: --disable-ffserver --enable-avfilter --disable-fastdiv --arch=m68k --enable-cross-compile --cross-prefix=m68k-amigaos- --enable-gpl --disable-debug --target-os=none
  libavutil    51.  2. 1 / 51.  2. 1
  libavcodec   53.  5. 0 / 53.  5. 0
  libavformat  53.  0. 3 / 53.  0. 3
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  5. 0 /  2.  5. 0
  libswscale    0. 14. 0 /  0. 14. 0
Input #0, image2, from 'Bretagne1.j2k':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0.0: Video: libopenjpeg, rgb24, 640x480, 25 tbr, 25 tbn, 25 tbc
[ffsink @ 0x10ab6bc0] auto-inserting filter 'auto-inserted scaler 0' between the filter 'src' and the filter 'out'
[scale @ 0x10ab73c0] w:640 h:480 fmt:rgb24 -> w:640 h:480 fmt:yuv420p flags:0x4
   0.67 A-V:  0.000 s:0.0 aq=    0KB vq=    0KB sq=    0B f=0/0   0/0   

Attachments (1)

ffplay.diff (619 bytes) - added by ami_stuff 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by ami_stuff

this is most likely duplicate of:

https://ffmpeg.org/trac/ffmpeg/ticket/141

the bigger file you use for test, the faster you will be able to reproduce this issue - i'm able to reproduce this also with big jpg files
(at least 3 secs. must pass between run of the ffplay command and 100% image decode, so maybe problem with threads synchro?)

but the problem doesn't happened in the past, so it's a regression.

comment:2 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from new to closed

Seems fixed

Note: See TracTickets for help on using tickets.