Opened 6 years ago

Closed 6 years ago

#1729 closed defect (needs_more_info)

avformat sdp.c error.

Reported by: kyh96403 Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: sdp ffserver
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
FFserver cannot work RTSP when video codec is H.264 or H.263.
Because sdp.c's function "sdp_write_media_attributes" have bug.
"fmt->oformat" can have NULL.

So "if (fmt && fmt->oformat->priv_class &&" -> "if (fmt && fmt->oformat && fmt->oformat->priv_class"
And "if (!fmt || !fmt->oformat->priv_class ||" -> "if (!fmt || !fmt->oformat || !fmt->oformat->priv_class ||"

Change History (3)

comment:1 Changed 6 years ago by cehoyos

  • Keywords avformat removed

Please either attach patches made with "git diff>change.diff" or "git format-patch" to the ticket, or send them to ffmpeg-devel (patches generally receive more attention on ffmpeg-devel).

comment:2 Changed 6 years ago by michael

Please provide sufficient information, including any required input files, to reproduce the bug and confirm a potential fix.

comment:3 Changed 6 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can add the missing information (and if the problem is still reproducible).

Note: See TracTickets for help on using tickets.