Opened 6 years ago

Last modified 6 years ago

#1712 open defect

Audio precision in lossless and long time to encode.

Reported by: Danixu Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Summary of the bug:
Hi, first of all, i'm sorry for my english.
I've tried the last ffmpeg build and i get a problem with Audio precision in lossless audio file, the audio is delayed about 2 seconds.
The audio is passed to another program throught a pipe, but i know that the other program isn't the problem, because with a very old ffmpeg version (SVN 16573, Jan 13 2009) works fine, and i've tried with wav output without pipe and get the same problem.

If you want, here's a test wav files: http://www.mediafire.com/?1ewceliyjhspedk

The command line that i've used is :
ffmpeg_old -i "input.ape" -ss 00:59:18.71 -t 00:00:15.55 out_oldffmpeg.wav
ffmpeg -i "input.ape" -ss 00:59:18.71 -t 00:00:15.55 out_newffmpeg.wav

How to reproduce:

% ffmpeg -i input -ss 00:45:25 -t 00:05:25 -ac 2 -f wav -

The output is a pipe to another program.

'''ffmpeg version''' N-44080-gdfb4757
'''built on''' Aug 31 2012 16:58:51 with gcc 4.7.1 (GCC)
configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runt
ime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass -
-enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-l
ibfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopenj
peg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheo
ra --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-li
bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --ena
ble-zlib

The other thing that i wan to answer is why the program take a long time to convert a portion of a file, for example:
ffmpeg -i input.ape -ss 00:45:15.42 -t 00:00:15.25 output.wav

the program stay a long time without do anything and then start to convert. I take about 2 minutes to convert 15s of audio.

Change History (5)

comment:1 Changed 6 years ago by Cigaes

Does this happen only with APE files, or does it happen also if you first convert the whole file to WAV or FLAC?

Concerning the second issue you mention, this is completely normal: since you put the -ss option after the -i option, it works by skipping: the input file is decoded and the unwanted samples are dropped. This is slower but more accurate than seeking, which is used when -ss is before -i.

comment:2 Changed 6 years ago by Danixu

I think that is only with APE files, because i've tried with a FLAC and works, then i've converted that FLAC to APE and the problem back again. With WAV works fine.

Thanks for the answers.

comment:3 Changed 6 years ago by Cigaes

  • Analyzed by developer set
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Possible explanation of the problem here:
http://ffmpeg.org/pipermail/ffmpeg-devel/2012-September/130449.html
No fix yet. Thanks for the report.

comment:4 Changed 6 years ago by Danixu

Thank you for your attention :)

comment:5 Changed 6 years ago by Danixu

Hi again friend, i've seen that if i use -ss xx:xx:xx.xx before -i the position is more accurate than if i put it after -i.

I comment because maybe is useful.

Bye ;)

Note: See TracTickets for help on using tickets.