Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1681 closed defect (fixed)

Bad output framerate decision

Reported by: jwjwjw Owned by:
Priority: important Component: avformat
Version: git-master Keywords: regression framerate edts
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

The attached sample file does not play properly once encoded in ffmpeg using the latest git-master. The video either freezes while the audio plays or the video is too jerky. During the encode the following appears:

[mov,mp4,m4a,3gp,3g2,mj2 @ 0x65e240] multiple edit list entries, a/v desync might occur, patch welcome

Despite this though, the file does encode and play fine (including the above message during the encode process) using earlier version N-31890-gecaf514 so I reasonably conclude that it is a regression bug.

How to reproduce:

% ffmpeg -i bbc1_sample.mp4 -report bbc1_freeze.mp4
ffmpeg version N-43888-gfef9e84 Copyright (c) 2000-2012 the FFmpeg developers
  built on Aug 25 2012 01:37:52 with gcc 4.4.5 (Debian 4.4.5-8)
  configuration: --enable-libdc1394 --prefix=/usr --extra-cflags='-Wall -g ' --enable-shared --enable-libmp3lame --enable-gpl --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-avfilter --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --extra-libs=-lgcrypt --disable-altivec --disable-armv5te --disable-armv6 --disable-vis

Attachments (4)

bbc1_sample.mp4 (2.0 MB) - added by jwjwjw 6 years ago.
Partial sample original mp4 file used during encode process
bbc1_freeze.mp4 (637.2 KB) - added by jwjwjw 6 years ago.
Encoded file using latest git-master
bbc1_ok.mp4 (519.9 KB) - added by jwjwjw 6 years ago.
Encoded file using N-31890-gecaf514
ffmpeg-20120825-134002.log (35.7 KB) - added by jwjwjw 6 years ago.
Report log of encode process using latest git-master

Change History (8)

Changed 6 years ago by jwjwjw

Partial sample original mp4 file used during encode process

Changed 6 years ago by jwjwjw

Encoded file using latest git-master

Changed 6 years ago by jwjwjw

Encoded file using N-31890-gecaf514

Changed 6 years ago by jwjwjw

Report log of encode process using latest git-master

comment:1 Changed 6 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from Frozen video, audio playing (regression) to Bad output framerate decision
  • Version changed from unspecified to git-master

Regression since 5c5306d, workaround is to use -r 25.

comment:2 Changed 6 years ago by cehoyos

  • Keywords framerate added

comment:3 Changed 6 years ago by michael

  • Component changed from undetermined to avformat
  • Keywords edit list added
  • Resolution set to fixed
  • Status changed from open to closed

comment:4 Changed 6 years ago by cehoyos

  • Keywords edts added; edit list removed
Note: See TracTickets for help on using tickets.