Opened 7 years ago

Closed 7 years ago

#1649 closed enhancement (fixed)

add a volumedetect audio filter

Reported by: dericed Owned by:
Priority: wish Component: avfilter
Version: git-master Keywords: volume volumedetect
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

There is a nice volume audio filter that enables the audio volume to be raised or lowered according to a fraction or db value. I often need to create media files where the audio volume is scaled to a specified db value. Right now to do this I have to pipe from ffmpeg to normalize (to get the volume expressed in db), then do the math to determine the difference between the volume I have and the volume I want, and then use the volume filter in ffmpeg to make that adjustment.

I suggest that ffmpeg add a volumedetect filter to assess the volume of an audio stream (similar to how normalize does) as it would be nice to do this process in one tool.

I think the combination of cropdetect and crop is similar to this request, since cropdetect can be used on a first pass to determine an appropriate crop and then the returned value can be used in the crop filter of a second pass. Doing something similar with a volumedetect filter then the existing volume filter would be very useful.

Change History (3)

comment:1 Changed 7 years ago by Cigaes

  • Component changed from undetermined to avfilter
  • Keywords avfilter removed
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:2 Changed 7 years ago by cehoyos

  • Priority changed from normal to wish

comment:3 Changed 7 years ago by saste

  • Analyzed by developer set
  • Keywords volumedetect added
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Shoulld be fixed by the volumedetect filter, added in:

commit 5980e57cf9a08ca284bc1b5ffba2363f9eff8ca8
Author: Nicolas George <nicolas.george@normalesup.org>
Date:   Sat Aug 18 13:49:47 2012 +0200

    lavfi: add volumedetect filter.
Note: See TracTickets for help on using tickets.