Opened 5 years ago

Closed 5 years ago

#1571 closed enhancement (fixed)

Make "concat" muxer/demuxer which will act like "image2"

Reported by: burek Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: concat
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Since a lot of people are trying to use ffmpeg to concat their media files lately, it would make sense to maybe create a muxer/demuxer that will act like image2 mux/demux, which would read several input files, one after another (like a playlist) and would produce a useful output for filters/encoders further in the processing chain.

Showcase:

ffmpeg -f concat -i "input1:input2:input3" -acodec .. -vcodec .. output

Change History (3)

comment:1 Changed 5 years ago by richardpl

  • Resolution set to wontfix
  • Status changed from new to closed

You are not aware what -f really means - it is format/container, concast is neither.

There is protocol concat and will work but not for always simply because that is not possible with bunch of retarded (non-stremable) formats.

comment:2 Changed 5 years ago by Cigaes

  • Resolution wontfix deleted
  • Status changed from closed to reopened

There is nothing "retarded" about formats that can not be concatenated, and it has not much to do with streamable. Furthermore, even if these formats were, for some reason, "retarded", there are currently enough people who use them to warrant implementing things for them.

Concatenating at the demuxer level makes a lot of sense if the files that are being concatenated have the same streams with the same codecs in them: it is just a matter of outputting the packets of the second file after the packets of the first one, possibly adjusting the timestamps.

comment:3 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords concat added
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from unspecified to git-master

The concat demuxer was implemented by Clément Bœsch.

Note: See TracTickets for help on using tickets.