Opened 4 years ago

Closed 3 years ago

#1567 closed defect (fixed)

make install fails with relative path for prefix dir

Reported by: MacGyverismo Owned by:
Priority: minor Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

install fails because the working directory is changed twice in a single make-command.

How to reproduce:

download (latest) source
run configure with relative path for --prefix. ie. --prefix=install

result:
INSTALL	libavdevice/libavdevice.so
STRIP	install-libavdevice-shared
cd: 1: can't cd to install/lib

this seems to be because the command which is executed actually changes from working dir to install/lib ( which is good ) and then another cd command is executed ( also to install/lib ) but this fails because the working dir was already set to this directory.

Change History (2)

comment:1 Changed 4 years ago by cehoyos

  • Keywords relative path configure removed
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Only reproducible with --enable-shared
Culprit is the following line in "install-lib$(NAME)-shared:"

$(Q)$(foreach F,$(SLIB_INSTALL_LINKS),cd "$(SHLIBDIR)" && $(LN_S) $(SLIB_INSTALL_NAME) $(F);)

comment:2 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Cyrille Faucheux in 75758f84 / since 1.2

Note: See TracTickets for help on using tickets.