Opened 5 years ago

Closed 5 years ago

#1557 closed defect (fixed)

support old sipr in rm

Reported by: cehoyos Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: real sipr roundup
Cc: ami_stuff@o2.pl Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

(issue 1708)
http://samples.ffmpeg.org/real/RA/sipr/
Works fine with mplayer -demuxer rm -ac ffsipr, does not work correctly with ffmpeg and mplayer -demuxer lavf

$ ffmpeg -i big_16k.ra
ffmpeg version N-42619-g6b7849e Copyright (c) 2000-2012 the FFmpeg developers
  built on Jul 19 2012 08:58:35 with gcc 4.3.2
  configuration: --cc=/usr/local/gcc-4.3.2/bin/gcc --enable-gpl --enable-libopenjpeg --enable-libvorbis --enable-libspeex --enable-libmp3lame --enable-libtheora --extra-ldflags=-lm --enable-libvpx --enable-libxavs --enable-x11grab --enable-libass
  libavutil      51. 65.100 / 51. 65.100
  libavcodec     54. 41.100 / 54. 41.100
  libavformat    54. 17.100 / 54. 17.100
  libavdevice    54.  1.100 / 54.  1.100
  libavfilter     3.  2.100 /  3.  2.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[rm @ 0x90764e0] max_analyze_duration 5000000 reached at 5000000
[rm @ 0x90764e0] Estimating duration from bitrate, this may be inaccurate
Guessed Channel Layout for  Input Stream #0.0 : mono
Input #0, rm, from 'big_16k.ra':
  Metadata:
    title           : >
    author          :
    copyright       :
    comment         : ??D
  Duration: N/A, bitrate: N/A
    Stream #0:0: Audio: sipr (sipr / 0x72706973), 16000 Hz, mono, flt
At least one output file must be specified

Attachments (2)

rm.diff (502 bytes) - added by ami_stuff 5 years ago.
patchreal.diff (807 bytes) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by compn

  • Summary changed from Support demuxing SIPR on RA files to support old sipr in rm (rewrite rm demuxer)

these sipr samples work fine:
http://samples.ffmpeg.org/real/AC-sipr/

the samples in

http://samples.ffmpeg.org/real/RA/sipr/

are using an older format:
[07:16] <kshishkov> I suspect it's because big* files are in really old format
[07:17] <kshishkov> and they have Int0 interleaver instead of (expected) "sipr" interleaver

a rewrite of rm demuxer maybe useful.

comment:2 Changed 5 years ago by cehoyos

  • Keywords roundup added

comment:3 Changed 5 years ago by ami_stuff

at least RealAudio? Encoder 3.1 (1997) produces such files

comment:4 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from support old sipr in rm (rewrite rm demuxer) to support old sipr in rm

Changed 5 years ago by ami_stuff

comment:5 Changed 5 years ago by ami_stuff

  • Cc ami_stuff@o2.pl added

Attached hack fixes the problem.

comment:6 Changed 5 years ago by cehoyos

Could your patch break ATRAC decoding?

comment:7 Changed 5 years ago by ami_stuff

yes it breaks atrac3 in version 5 cointainer:

http://www.datafilehost.com/download-d27069ba.html

Changed 5 years ago by cehoyos

comment:8 follow-up: Changed 5 years ago by cehoyos

Could you test attached patch?

comment:9 in reply to: ↑ 8 Changed 5 years ago by ami_stuff

Replying to cehoyos:

Could you test attached patch?

Works fine with my samples.

comment:10 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Thank you for testing!

Note: See TracTickets for help on using tickets.