Opened 5 years ago

Closed 5 years ago

#1543 closed defect (needs_more_info)

ffmpeg stops after few minutes without anything in the log

Reported by: kostay Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: libx264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: ffmpeg just stops after random time and i see in task manager that it starts to eat the memory very fast
running on windows
build from zeranoe
tried at few pc's and few builds

How to reproduce:

ffmpeg -v debug -rtbufsize 204800000 -s 640x480 -f dshow -i video="Microsoft LifeCam HD-3000" -vcodec libx264 -tune zerolatency -pass 1 -profile:v baseline -preset ultrafast -pix_fmt yuv420p -crf 30 -x264opts fast_pskip=0:intra-refresh -threads 0 -bufsize 50k -maxrate 700k -s 640x480 -f h264 udp://10.0.0.4:7000

ffmpeg version
ffmpeg version N-42547-g7543fd8 Copyright (c) 2000-2012 the FFmpeg developers
  built on Jul 15 2012 21:41:57 with gcc 4.7.1

built on ... latest

Change History (5)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined

Did you provide the complete, uncut console output? Does it really stop with "built on"?

Is this also reproducible if you convert to a file instead of a network stream?
Is this also reproducible if you use an internal encoder (like -vcodec mpeg4 -f m4v) instead of libx264?

comment:2 Changed 5 years ago by kostay

no problems that way... (like -vcodec mpeg4 -f m4v)
but i need real time video which h264 provides as i could see

converting to file == same

end of the output of converting to file:
it just stopped on last line and strarted to eat memory again

kind regards

[libx264 @ 000000000051ef40] frame= 865 QP=30.00 NAL=2 Slice:P Poc:1730 I:3 P
:98 SKIP:1099 size=271 bytes
[libx264 @ 000000000051ef40] frame= 866 QP=30.00 NAL=2 Slice:P Poc:1732 I:4 P
:47 SKIP:1149 size=168 bytes
[libx264 @ 000000000051ef40] frame= 867 QP=30.00 NAL=2 Slice:P Poc:1734 I:7 P
:84 SKIP:1109 size=258 bytes
[libx264 @ 000000000051ef40] frame= 868 QP=30.00 NAL=2 Slice:P Poc:1736 I:5 P
:81 SKIP:1114 size=238 bytes
frame= 869 fps= 30 q=30.0 size= 346kB time=00:00:28.96 bitrate= 98.0kbits/
frame= 869 QP=30.00 NAL=2 Slice:P Poc:1738 I:14 P:134 SKIP:1052 size=353 byte
s
[libx264 @ 000000000051ef40] frame= 870 QP=30.00 NAL=2 Slice:P Poc:1740 I:10 P
:84 SKIP:1106 size=255 bytes
[libx264 @ 000000000051ef40] frame= 871 QP=30.00 NAL=2 Slice:P Poc:1742 I:3 P
:67 SKIP:1130 size=217 bytes
[libx264 @ 000000000051ef40] frame= 872 QP=30.00 NAL=2 Slice:P Poc:1744 I:3 P
:51 SKIP:1146 size=177 bytes
[libx264 @ 000000000051ef40] frame= 873 QP=30.00 NAL=2 Slice:P Poc:1746 I:3 P
:55 SKIP:1142 size=187 bytes
[libx264 @ 000000000051ef40] frame= 874 QP=30.00 NAL=2 Slice:P Poc:1748 I:3 P
:48 SKIP:1149 size=165 bytes
[libx264 @ 000000000051ef40] frame= 875 QP=30.00 NAL=2 Slice:P Poc:1750 I:11 P
:101 SKIP:1088 size=294 bytes
[libx264 @ 000000000051ef40] frame= 876 QP=30.00 NAL=2 Slice:P Poc:1752 I:4 P
:57 SKIP:1139 size=193 bytes
[libx264 @ 000000000051ef40] frame= 877 QP=30.00 NAL=2 Slice:P Poc:1754 I:10 P
:62 SKIP:1128 size=220 bytes
[libx264 @ 000000000051ef40] frame= 878 QP=30.00 NAL=2 Slice:P Poc:1756 I:3 P
:49 SKIP:1148 size=172 bytes
[libx264 @ 000000000051ef40] frame= 879 QP=30.00 NAL=2 Slice:P Poc:1758 I:2 P
:46 SKIP:1152 size=164 bytes

comment:3 Changed 5 years ago by kostay

i don't know what is the workflow here. so just asking

if i get no reaction (answer) for pretty long time means that i will get no answer at all?

regards

comment:4 Changed 5 years ago by cehoyos

  • Keywords libx264 added

Afaict, you did not provide complete, uncut console output (this is needed for every non-build non-documentation report). If the problem is only reproducible with -vcodec libx264, but not -vcodec mpeg4, then a problem outside of FFmpeg is likely. To make sure, consider providing a backtrace.

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen the ticket if you can provide the missing information.

Note: See TracTickets for help on using tickets.