Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#153 closed defect (fixed)

DVB Subtitles Streams decoding and encoding errors

Reported by: joolzg Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: dvbsub
Cc: er.anshul.maheshwari@gmail.com Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

These is a test stream that shows errors in the DVB Subtitle decoder and encoder.

Attachments (1)

bbc_small.ts (2.5 MB) - added by joolzg 8 years ago.
shows live audio transcoding dvb subtitles

Change History (16)

Changed 8 years ago by joolzg

shows live audio transcoding dvb subtitles

comment:1 Changed 8 years ago by joolzg

also i used some of the sample streams from here

http://www.screen.subtitling.com/html/mm%20downloads.html

comment:2 Changed 8 years ago by cehoyos

Has this been fixed by the latest changes to dvb?

comment:3 Changed 7 years ago by saste

  • Priority changed from important to normal
  • Status changed from new to open

How to test for the error, what's the expected result and what do you see?

Can you reproduce the error with latest FFmpeg?

Also please show complete command and log, consider using -report.

comment:4 Changed 7 years ago by saste

  • Summary changed from DVB Subtitles Test Streams to DVB Subtitles Streams decoding and encoding errors

comment:5 Changed 7 years ago by cehoyos

Playback with ffplay has not changed in the last 18 months for the attached sample.

comment:6 follow-up: Changed 5 years ago by cehoyos

  • Keywords dvbsub added; dvb subtitles removed

comment:7 in reply to: ↑ 6 Changed 5 years ago by er.anshul.maheshwari@gmail.com

As I am intrested in this report
cehoyos, can you briefly explain question asked by saste.

comment:8 Changed 5 years ago by cehoyos

How?

comment:9 Changed 5 years ago by er.anshul.maheshwari@gmail.com

When I run(decode using ffplay) the clip attached here, i see only problem is "Help"(subtile) having green color.

I dont see any error message while decoding at my place.

I just wanted to know what do we expect from dvb decoder or encoder.
This report shows only "we have error", what error is, Is it red colored error message or something unexpected at output. if output is different with other player or decoder then in what sense. which player did we checked to compare output.

comment:10 Changed 5 years ago by er.anshul.maheshwari@gmail.com

  • Cc er.anshul.maheshwari@gmail.com added

comment:11 follow-up: Changed 5 years ago by cehoyos

joolzg reported this ticket and Stefano asked him for more information.
I asked him recently for more information about this ticket:
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/175169/focus=175260
He apparently missed my question.

comment:12 in reply to: ↑ 11 Changed 5 years ago by saste

Replying to cehoyos:

joolzg reported this ticket and Stefano asked him for more information.
I asked him recently for more information about this ticket:
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/175169/focus=175260
He apparently missed my question.

The problem is related to the first text displayed by ffplay, the "help" word which looks corrupted (probably an alpha issue).

comment:13 Changed 5 years ago by cehoyos

I thought that the first subtitle is just incomplete (or damaged). Some media players probably prefer not to show damaged subtitles but FFmpeg (default!) behaviour was always to show everything that can be decoded. After all, "help" can be read.
If this is really the issue (I don't know), "help" should not be shown for -strict strict.

comment:14 Changed 4 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Fixed in 4b90dcb8493552c17a811c8b1e6538dae4061f9d
If other issues remain please open separate tickets

comment:15 Changed 4 years ago by cehoyos

I believe only joolzg can tell us if this issue was fixed...

Note: See TracTickets for help on using tickets.