Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1529 closed enhancement (fixed)

easier access to (ex: libx264) presets available

Reported by: rogerdpack Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: x264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello. Currently the "help" output refers one to the binary x264 (which may not be available, ex: on windows) for a list of presets. It would be convenient to have some way to enumerate them without needing a second executable.
ref: https://lists.ffmpeg.org/pipermail/ffmpeg-user/2012-June/007365.html
Or auto-add them to docu, etc.

Change History (6)

comment:1 Changed 4 years ago by cehoyos

  • Keywords x264 added
  • Priority changed from normal to wish
  • Version changed from unspecified to git-master

comment:2 Changed 4 years ago by Cigaes

In the laetst Git version, setting an invalid preset or tune will print the list:

[libx264 @ 0x99fea0] Error setting preset/tune help/(null).
[libx264 @ 0x99fea0] Possible presets: ultrafast superfast veryfast faster fast medium slow slower veryslow placebo
[libx264 @ 0x99fea0] Possible tunes: film animation grain stillimage psnr ssim fastdecode zerolatency

Note that help or list are invalid, and thus will have that result.

If this is acceptable to you, you can close the bug.

comment:3 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Resolution set to fixed
  • Status changed from new to closed

Afaict, this was fixed by Nicolas, please reopen if the solution is insufficient.

comment:4 follow-up: Changed 4 years ago by rogerdpack

Thanks this is great!
A few minor additions that might be helpful:
Since there are some "file based" presets that aren't listed (https://github.com/FFmpeg/FFmpeg/tree/master/presets ) the output text might be better served as "Possible tunes (doesn't include external files):" or something like that.

Also a similar help output message for bad h264 profiles would be convenient, as well, but not necessary. Thanks!

comment:5 in reply to: ↑ 4 Changed 4 years ago by Cigaes

Replying to rogerdpack:

Since there are some "file based" presets that aren't listed (https://github.com/FFmpeg/FFmpeg/tree/master/presets ) the output text might be better served as "Possible tunes (doesn't include external files):" or something like that.

I am afraid this is difficult: -vpre and its presets is specific to the ffmpeg command-line tool, while this error message comes from the library, and could appear in another application that does not have that kind of presets.

Also a similar help output message for bad h264 profiles would be convenient, as well, but not necessary. Thanks!

Patch for that posted:
http://ffmpeg.org/pipermail/ffmpeg-devel/2012-July/128463.html
It will be possible to fix your name in the commit message if you want until this is pushed in the official repository.

comment:6 Changed 4 years ago by rogerdpack

Ok that makes sense (changing the error message to say "Possible internal tunes" might still be a small improvement.

Patch looks great.
Thanks for doing that!
-roger-

Note: See TracTickets for help on using tickets.