Opened 10 years ago

Closed 4 years ago

#1496 closed enhancement (invalid)

Stream passthru : VideoCodec copy

Reported by: Lupu Owned by:
Priority: wish Component: ffserver
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

FFserver does not support FFmpeg's "-vcodec copy" or "-acodec copy"
VideoCodec copy
AudioCodec copy

1) "-vcodec/-acodec copy" is very useful when you just want to change the container of the stream

2) If you have output streams at various bitrates: high(same as input feed), low;
then only the low quality stream would need to be re-encoded saving cpu time.

Change History (5)

comment:1 by Carl Eugen Hoyos, 10 years ago

Keywords: transcoding vcodec acodec copy removed
Priority: normalwish
Status: newopen
Version: unspecifiedgit-master

comment:2 by onitake, 6 years ago

Is there any activity on this feature?

Would it be difficult to implement it?
I have a use case where prevention of transcoding is a requirement, so I'd like to see it implemented soon.

For some reason, ffserver 2.4 actually supported this if you didn't configure the codec in ffserver.conf. In newer versions, transcoding seems to be enforced, and with very low default settings if you don't specify any.

comment:3 by Timo R., 6 years ago

ffserver is essentialy unmaintained.
If you send patches they'd most likely be happily accepted, but I think it's unlikely anyone will pick up ffserver anytime soon.

comment:4 by onitake, 6 years ago

Too bad.

But I'll give it a shot.
Can't be too hard, right? :)

comment:5 by Rostislav Pehlivanov, 4 years ago

Resolution: invalid
Status: openclosed

ffserver was removed from git master, closing bug as invalid

Note: See TracTickets for help on using tickets.