Opened 5 years ago

Closed 5 years ago

#142 closed defect (invalid)

[FFmpeg/filters/overlay] PNG over a movie doesn't look write in 0.7

Reported by: stepho Owned by: michael
Priority: normal Component: avfilter
Version: 0.7-rc1 Keywords: overlay
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm trying to overlay a static PNG file over a movie with FFmpeg 0.7-rc1 but the PNG file is not rendered correctly.
The same command line produces the expected result with FFmpeg 0.6.9-rc0.

ffmpeg -v 9 -loglevel 99 -i chuck_intro_lq.webm -acodec copy -vf "movie=vert_100x100x32.png [wm];[in][wm] overlay=W-w-10:H-h-10 [out]" chuck_intro_lq_overlay_ffmpeg-0.7-rc1.webm

Please note that I've also tried with libxvid codec and an avi container; the result is the same (not correctly rendered picture).

The picture is a plain opaque green square saved in a 32bits PNG (with alpha channel).

It may be that I'm doing something wrong, but why was it working in 0.6.9-rc0.

Attachments (6)

chuck_intro_lq_overlay_ffmpeg-0.7-rc1.webm (502.7 KB) - added by stepho 5 years ago.
Resulting movie (ffmpeg 0.7-rc1) with damaged "logo"
chuck_intro_lq_overlay_ffmpeg-0.6.9-rc0.webm (480.2 KB) - added by stepho 5 years ago.
Resulting movie (ffmpeg 0.6.9-rc0) with good "logo"
chuck_intro_lq.webm (499.1 KB) - added by stepho 5 years ago.
Source movie
vert_100x100x32.png (309 bytes) - added by stepho 5 years ago.
"logo" PNG file
ffmpeg_0.7-rc1_overlay.log (119.5 KB) - added by stepho 5 years ago.
Complete console output from ffmpeg 0.7-rc1
ffmpeg_0.6.9-rc0_overlay.log (119.5 KB) - added by stepho 5 years ago.
Complete console output from ffmpeg 0.6.9-rc0

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by stepho

Resulting movie (ffmpeg 0.7-rc1) with damaged "logo"

Changed 5 years ago by stepho

Resulting movie (ffmpeg 0.6.9-rc0) with good "logo"

Changed 5 years ago by stepho

Source movie

Changed 5 years ago by stepho

"logo" PNG file

Changed 5 years ago by stepho

Complete console output from ffmpeg 0.7-rc1

Changed 5 years ago by stepho

Complete console output from ffmpeg 0.6.9-rc0

comment:1 Changed 5 years ago by stepho

Hi again,

I've tried with a more recent version of FFmpeg (downloaded en built on 2011-05-08).
The overlay works just fine.

Sorry for the disturbance.

Stépho.

PS: great work, by the way, I love FFmpeg !! :-)

comment:2 Changed 5 years ago by saste

  • Resolution set to invalid
  • Status changed from new to closed

Reporter is reporting he can't reproduce the problem anymore, so I'm closing the issue.

Note: See TracTickets for help on using tickets.