Opened 6 years ago

Closed 6 years ago

#1356 closed defect (fixed)

Fail to build for kfreebsd in libavformat/sctp.c

Reported by: marillat Owned by:
Priority: normal Component: build system
Version: 0.11 Keywords:
Cc: michael Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hi,

0.11 fail to build for KfreeBSD (Debian Unstable) with this error :

In file included from libavformat/sctp.c:41:0:
/usr/include/netinet/sctp.h:35:10: error: expected declaration specifiers or '...' before string constant
In file included from /usr/include/netinet/sctp.h:543:0,
                 from libavformat/sctp.c:41:
/usr/include/netinet/sctp_uio.h:35:10: error: expected declaration specifiers or '...' before string constant
libavformat/sctp.c: In function 'ff_sctp_send':

You can find the build log here :

http://grouchy.esiee.fr/logs/ffmpeg-dmo_0.11-dmo1-kfreebsd-amd64-20120527-0017

Change History (5)

comment:1 Changed 6 years ago by marillat

I've found where I've already seen a fix for that.
Here is the log entry for svn revision 34896 in mplayer.

r34896 | al | 2012-05-13 21:55:27 +0200 (dim. 13 mai 2012) | 12 lignes

build: Check if SCTP is available

  Test for SCTP and remove it from the list of libavformat
protocols in case the test did not succeed or the feature
was explicitly disabled.

  Unconditionally trying to build it, as it was done before
if you had a new enough libavformat version that contains
that feature, is obviously not a good idea.

  This patch is closely based on a patch from Johan Andersson.

comment:2 follow-up: Changed 6 years ago by michael

  • Status changed from new to open

Sorry for the late reply
The build log link is sadly 404, but iam not sure it would help
about the mplayer check, we check for the header as well but obviosuly this isnt enough.
the relevant part of our configure is
check_header netinet/sctp.h
and
sctp_protocol_deps="network netinet_sctp_h"

the error you quote is in the system header though which is a bit odd and would indicate that the header is buggy. Seeing the content of the systemheader in which the error happens may help understand better where the problem is

comment:3 Changed 6 years ago by michael

  • Cc michael added

comment:4 in reply to: ↑ 2 Changed 6 years ago by marillat

Replying to michael:

the error you quote is in the system header though which is a bit odd and would indicate that the header is buggy. Seeing the content of the systemheader in which the error happens may help understand better where the problem is

You can find headers here :

http://ftp.de.debian.org/debian/pool/main/k/kfreebsd-kernel-headers/kfreebsd-kernel-headers_0.82.tar.gz

comment:5 Changed 6 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Fixed in git master, ill backport it to 0.11

Note: See TracTickets for help on using tickets.