Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#135 closed defect (fixed)

-acodec copy does not copy wav file correctly (at least with with pcm_s24le )

Reported by: NabilStendardo Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: wav
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

What we have:

An audio file encoded in wav pcm_s24le(let us call it a.wav) from the output of a previous ffmpeg command.

What we want:
To execute:

$ffmpeg -i a.wav -acodec copy b.wav

and have an identical (and valid) wav file.

What we get with cmp:

$cmp -b a.wav b.wav

a.wav b.wav differ: byte 39, line 1 is 30 X 0 @

Of course 30 is octal for 24, which is the expected value from the first file (bits per sample). 0 here is clearly wrong. Note that b.wav does not play under gstreamer (which is somewhat normal because it is AFACT invalid)

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Status changed from new to open

Please add the complete, uncut output of your ffmpeg command.

comment:2 Changed 5 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from open to closed

fixed locally will push soon

comment:3 Changed 5 years ago by cehoyos

  • Keywords wav added
Note: See TracTickets for help on using tickets.