Opened 9 years ago

Closed 6 years ago

#1306 closed enhancement (fixed)

Open EXR : wrong processing of an *.exr files

Reported by: robocop Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: EXR
Cc: ami_stuff@o2.pl Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Looks there is some mistake in EXR format support in ffmpeg.
I`m tried to convert simple exr image file to jpeg, but get funky-noissy image as result :
http://i112.photobucket.com/albums/n173/russiaman/tmp/test_exr_out.jpg

Exact the same noisy image is appear, when i`m try to view exr file via ffplay.

there is a commandline i`ve used to convert:
ffmpeg.exe -f image2 -i d:\tmp\test_exr.exr d:\tmp\sq2mv\test_exr_out.jpg

in console i get one message many times:
[exr @ 0000000001e60940] Line offset for line 804 is out of reach setting it to black
there is a screenshoot:
http://i112.photobucket.com/albums/n173/russiaman/tmp/ffmpeg_exr_bug.jpg

In attachments i put my source exr file and output jpg generated by ffmpeg.

Attachments (2)

test_exr.exr (102.3 KB ) - added by robocop 9 years ago.
test_exr_out.jpg (452.1 KB ) - added by robocop 9 years ago.

Download all attachments as: .zip

Change History (13)

by robocop, 9 years ago

Attachment: test_exr.exr added

by robocop, 9 years ago

Attachment: test_exr_out.jpg added

comment:1 by compn, 9 years ago

the person who created the exr patch said he might start working on the other exr subencoders. so , no ETA on how long it will be until its fixed.

comment:2 by Carl Eugen Hoyos, 9 years ago

Priority: importantnormal

To make this a valid ticket, please add complete, uncut console output (it is usually unnecessary to attach the output file).

comment:4 by Carl Eugen Hoyos, 9 years ago

Priority: normalwish
Reproduced by developer: set
Status: newopen
Type: defectenhancement
Version: unspecifiedgit-master

A patch by Jean First was committed that stops FFmpeg from trying to decode the sample, so this is a feature request now.

comment:5 by robocop, 9 years ago

I`ve tried now FFmpeg Builds Version: git-9c27f29 (2012-05-27), and get error message :

y:\ffmpeg\ffmpeg.exe -f image2 -i d:\tmp\test_exr.exr d:\tmp\sq2mv\out_%04d.jpg
ffmpeg version N-41074-g9c27f29 Copyright (c) 2000-2012 the FFmpeg developers
  built on May 27 2012 13:22:28 with gcc 4.6.3

[exr @ 01f3d1c0] This type of compression is not supported
[image2 @ 01f3c640] decoding for stream 0 failed
[image2 @ 01f3c640] Could not find codec parameters (Video: exr)
d:\tmp\test_exr.exr: could not find codec parameters

So ffmpeg now have no support for exr images at all :)?

comment:6 by Carl Eugen Hoyos, 9 years ago

http://samples.ffmpeg.org/image-samples/exr/ contains a working sample, compression is not supported, patch welcome!

comment:7 by ami_stuff, 9 years ago

Cc: ami_stuff@o2.pl added

here is a full set of samples if someone will decide to implement more features to exr decoder:

http://www.datafilehost.com/download-411f7a8d.html

comment:8 by Elon Musk, 9 years ago

ZIP1 and ZIP16 compression are now supported.

comment:9 by robocop, 9 years ago

richardpl thank you very much for update!
I`ve been tried playing with ffmpeg-20120720-git-85761ef-win64-static build.. and really - now zip1 and zip16 works well! COOL!

How about "Tiled exr" - ffmpeg didn`t works with them now :(
i get error message:
Tile based images are not supported.

there is a link for tiled exr example.
http://www.datafilehost.com/download-669b605c.html

comment:10 by Elon Musk, 9 years ago

I still don't have motivation to do this for free.

comment:11 by Elon Musk, 6 years ago

Resolution: fixed
Status: openclosed

Tile. MultiResolution and rest of compression types are now supported.

Note: See TracTickets for help on using tickets.