Opened 6 years ago

Closed 4 years ago

#1252 closed defect (worksforme)

Build error on PPC64 linux with "-m64"

Reported by: thinkbrown Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: ppc
Cc: michael Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I attempted to build a PPC64 version of FFMPEG, and when the build system trys to ld ffprobe_g, it returns an error:

/usr/bin/ld: libavcodec/libavcodec.a(iff.o)(.text.unlikely+0x188): sibling call optimization to .opd' does not allow automatic multiple TOCs; recompile with -mminimal-toc or -fno-optimize-sibling-calls, or make .opd' extern

/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status

The configure command I used is as follows:

./configure --enable-gpl --enable-version3 --enable-nonfree --enable-libx264 --extra-cflags="-m64 -mcpu=G5 -mtune=G5 -mpowerpc64 -maltivec -fno-optimize-sibling-calls" --extra-cxxflags="-m64 -mcpu=G5 -mtune=G5 -mpowerpc64 -maltivec -fno-optimize-sibling-calls" --extra-ldflags="-m64 -mcpu=G5 -mtune=G5 -mpowerpc64 -maltivec -fno-optimize-sibling-calls"

I already built a 64bit version of libx264 to build against.

I checked the version of FFMPEG that built in the directory, and it exectutes and is a 64bit executable. A test encode shows that it's about twice as fast as a 32bit build (using command ./ffmpeg -i ~/Desktop/file.mpg -vcodec libx264 -preset medium -crf 16 -acodec copy ~/Desktop/file.mkv) I get around 20fps vs. 9fps on a 32bit build.

Change History (5)

comment:1 Changed 6 years ago by michael

googling for this error message points to a gnu ld bug. I dont know if this issue here is caused by that bug or not but if you can , please try a different compiler and or different linker. (especially one that is known to have this bug fixed) Also please tell us the exact versions of the tools used to build

comment:2 Changed 6 years ago by michael

btw if someone knows where i can find a cross compiler for ppc64 (some debian or ubuntu package ideally) or some simple description of how to build one then this should be easy to resolve.

comment:3 Changed 6 years ago by michael

  • Cc michael added

comment:4 Changed 6 years ago by michael

  • Priority changed from important to normal

Also as theres no reply to my questions from 3 month ago this bug is not important. evidently noone cares enough to awnser them so i downgrade to normal priority

comment:5 Changed 4 years ago by cehoyos

  • Keywords ppc added
  • Resolution set to worksforme
  • Status changed from new to closed

I just tested compilation on a Linux PPC64 server and it succeeds (including fate).

Note: See TracTickets for help on using tickets.